C-Command Software Forum

Spamsieve keeps crashing

Suddenly, Spamsieve 2.7.3 is continually crashing. I’ve tried restarting the computer, but same problem. I tried downloading 2.7.4 but when I attempt to open the disk image I’m told “broken pipe.” I’m running OSX 10.4.11. What to do?

According to the crash report that you sent in, the crash is happening in the OS’s Launch Services subsystem when SpamSieve downloads the new version. It’s probably not directly related to SpamSieve. I suggest that you download SpamSieve 2.7.4 with your browser and follow the instructions in the Read Me file to replace your old version with it.

I have just done what you suggested (this is the third time). I’m attaching the error message that comes up when I double-click the downloaded file.

This error probably means that your downloaded file is damaged or incomplete. Since the file on the server is correct (I’ve just tested it, and no one else has reported problems) I think the problem is on your Mac or network. Perhaps it would help to download the file using Firefox if you were using Safari (or vice-versa) in case there’s a problem with the browser cache.

I’m getting the identical error after downloading from Camino, Safari, and Firefox. Can you provide any pointers on what might be wrong with my Mac or possible trouble-shooting steps I can take? Thanks,

Stan

Please open Terminal in your Utilities folder. Type “md5”, then a space, then drag the SpamSieve-2.7.4.dmg file into the window and press Return. What does it say? On my Mac, it shows:

MD5 (<location of the file>/SpamSieve-2.7.4.dmg) = 2fcc68901c9c429bb72d0281c75c8787

I get:

MD5 (/Users/stan/Desktop/Inbox/SpamSieve-2.7.4.dmg) = 2fcc68901c9c429bb72d0281c75c8787

That means the file has downloaded correctly, but that you can’t open it due to some other problem on your Mac that’s affecting Mac OS X’s disk image subsystem. I have no idea how to fix that other than perhaps a reinstall of the OS or of the most recent combo update (as described in these threads).

As to SpamSieve, downloading it in Zip format would allow you to access it without using the disk image subsystem.

Thank you for the zip. Hopefully this will stop the crashing problem. I’ll check into the disk image subsystem issue separately.