C-Command Software Forum

SpamSieve keeps ignoring whitelisted emails.

Predicted: Spam (100)
Subject: Automated Reply <AR127014>] {807102}
From: email@site.nl
Identifier: CcnVLwzR3D7ykX+oPwX2Pg==
Reason: has encoded HTML part
Date: 2016-01-08 13:59:06 +0100 (GMT+1)

How can I turn off the HTML encoding check for just one site? Or any other method that will get me these emails? When I manually train them as good, they get deleted!

I’ve rummaged through the various menu items in SpamSieve itself, and found a whitelist. I’ve changed one of the entries for the address to “Contains” and the Text To Match to @site.nl. In other threads you said that the HTML thing is evaluated very late in the process, so I guess this should work. These email are from a bank I am opening an account with, so I am not surprised that the messages are Base64 encoded.

What I do find strange though is the following:

  • I saw the messages in the garbage bin.
  • selected them
  • “Message” > “SpamSieve - Train As Good”
  • the selected messages get deleted for real!

Is that expected behavior? I doubt it.

It looks like there are multiple problems here.

Turning off Encoded HTML mail is spam will fix the direct problem by preventing SpamSieve from classifying the messages as spam because of “has encoded HTML part”.

However, this should probably not be necessary. Normally, you just need to train a message as good, and SpamSieve will automatically add the address to the whitelist. So there should already be a whitelist rule for this address. And the whitelist has higher priority than “Encoded HTML mail is spam.”

Secondly, of course, your manually created whitelist rule should have also worked. Do you perhaps have Use SpamSieve whitelist unchecked? Or are the rules for “email@site.nl” and “@site.nl” unchecked?

Training a message as good should move it to the inbox, not make it disappear. Please see this page.

I have just added the domain to the Whitelist. I’ll have to wait and see what happens when they (re-)send an email message.

I cannot find the original email message anywhere. I searched in Apple Mail and it didn’t find anything. Went online to my emailprovider and checked the various emailboxes on their server. Completely gone. I am not on a network at home, so I can’t think of other places to look.

Are you using more than one computer with this e-mail account? Did you try rebuilding Mail’s database as suggested on that page?

I do check them on my iPhone and iPad, but as far as computers go this is just the one computer checking that my email.

I tried rebuilding the Trash and Inbox from the account it was sent to, but that didn’t help. Those emails are in bit-heaven.

Why the Trash? Did you have it set to put the spam in the Trash instead of the Spam mailbox? In any case, it might help to do the full database rebuild instead.

If you look in the Accounts section of Mail’s Preferences window, are there any accounts shown as Inactive in the list?

In any case, since there’s no way that SpamSieve can prevent Mail from losing messages, I recommend that you set SpamSieve not to tell Mail to move good messages when training them.

I had the Apple Mail - Server Junk Mailbox.scpt set to automatically trash the blue and grey messages. One thing I turned off as of yesterday.

If you look in the Accounts section of Mail’s Preferences window, are there any accounts shown as Inactive in the list?
Nope. All three accounts are active.

In any case, since there’s no way that SpamSieve can prevent Mail from losing messages, I recommend that you set SpamSieve not to tell Mail to move good messages when training them.
Thanks. Walked through the questionnaire and made it so it doesn’t move messages to the Inbox.

We’ll see what happens in the coming days, after all I am still waiting on a re-send of the original emails, lol.

Thanks so far.

I noticed another message in the Trash getting “spammed” because of the encoded HTML, so I’ve turned it off!

When I told SpamSieve that message was good it was deleted from the Trash even though I had it set to not move messages to the Inbox. Is there a way that I can see the current configuration? I only have a bunch of windows popping up asking me stuff; not a clue what the current state is…

The current state is shown by which button is the default. You can also see it by entering this command in Terminal:

defaults read com.c-command.SpamSieve AppleMailTrainGoodMove

Now it’s completely the other way around…
Hi Michael,


Predicted: Spam (99)
Subject: Last places !!!Personal invitation to the Iberian MICE Forum Alicante-Costa Blanca, 28 February - 01 March 2016
From: x@x.com
Identifier: RntBT1VsLXgHlMnerM4olQ==
Reason: (
"x@x.com"
) matched rule <From (address) Is Equal to "x@x.com"> in SpamSieve blocklist
Date: 2016-01-26 10:24:15 +0100 (GMT+1)

SpamSieve decides it is spam (which is correct), yet it leaves it in the Inbox… (I’ve changed the email address to protect the guilty).

Is there a way I can reset the complete settings to default without getting rid of the various lists it has built in the last few years? In short, the program worked like a charm until I updated to the last Apple Mail - Server Junk Mailbox.scpt and started messing with the possibility of coloring the spams. I’ve reset those to false for every possible delete variable and done the Change Settings thing to make sure that Train Good - spams aren’t moved to the Inbox and turning off the encoded html.

Until yesterday I noticed that all messages from the Inbox that were deemed spam were still deleted (I thought I turned that off!), so I went through the Change Settings another time. Now this happens…


Predicted: Spam (96)
Subject: 1 Missed H00kup Call
From:
Identifier: AxduC5o8QzHl8jHGcQnOLA==
Reason: P(spam)=1.000[1.000], bias=0.000, x-xs4all-dnsbl-warning:cbl.abuseat.org(1.000), x-xs4all-dnsbl-warning:cbl(1.000), x-xs4all-dnsbl-warning:abuseat(1.000), x-xs4all-dnsbl-warning:zen.spamhaus.org(1.000), x-xs4all-dnsbl-warning:zen(1.000), x-xs4all-dnsbl-warning:bl.spamcop.net(1.000), x-xs4all-dnsbl-warning:xbl.spamhaus.org(1.000), x-xs4all-dnsbl-warning:net(1.000), x-xs4all-dnsbl-warning:xbl(1.000), x-xs4all-dnsbl-warning:bl(1.000), x-xs4all-dnsbl-warning:spamcop(1.000), R:^mx(1.000), R:^net^mx(0.999), x-xs4all-dnsbl-warning:sbl.spamhaus.org(0.999), R:^177(0.999)
Date: 2016-01-26 19:02:28 +0100 (GMT+1)

Predicted: Spam (96)
Subject: 1 Missed H00kup Message
From:
Identifier: nhx9sY8ihKMFROWzeII5ag==
Reason: P(spam)=1.000[1.000], bias=0.000, x-xs4all-dnsbl-warning:cbl.abuseat.org(1.000), x-xs4all-dnsbl-warning:cbl(1.000), x-xs4all-dnsbl-warning:abuseat(1.000), x-xs4all-dnsbl-warning:zen.spamhaus.org(1.000), x-xs4all-dnsbl-warning:zen(1.000), x-xs4all-dnsbl-warning:bl.spamcop.net(1.000), x-xs4all-dnsbl-warning:xbl.spamhaus.org(1.000), x-xs4all-dnsbl-warning:net(1.000), x-xs4all-dnsbl-warning:xbl(1.000), x-xs4all-dnsbl-warning:bl(1.000), x-xs4all-dnsbl-warning:spamcop(1.000), R:^mx(1.000), R:^net^mx(0.999), x-xs4all-dnsbl-warning:sbl.spamhaus.org(0.999), A:pictures(0.999)
Date: 2016-01-26 20:27:58 +0100 (GMT+1)

Two more, …

Long live Time Machine, as I restored the plist from January 1st (I think that was before everything started to go belly-up) as a replacement. It seems to be working, or rather when I trained them as Spam they got moved to the SpamSieve box as I want. Hopefully new messages will be moved as well. On the bright side, the downloaded Junkmail script works as normal (I believe) as I saw the Hushmail Junkbox being moved to the SpamSieve collector as well.

Good. However, the preferences file and Change Settings only affect what happens when you train messages. What happens to incoming messages is determined by the rule in Mail (or the script).

Thanks for reminding me! That was the reason nothing got deleted! I had turned off Spam Coloring in the Change Settings yet not adjusted the rules. In other words, nothing got a color, nothing got deleted.

You made an awesome program, but configuring it is not an easy thing. lol

Change Settings is a known area that confuses people. I’m working on making that easier in a future version.