C-Command Software Forum

SpamSieve never deletes messages?

I have experienced messages " disappearing" in front of my eyes since I installed SpamSieve. I read several times in this forum that SpamSieve never deletes messages and I already followed some of the suggested tips to solve this issue:

  • Left SpamSieve running in only 1 Mac
  • Rebuild Apple Mails’s envelop in my 2 Macs
  • Made sure that all Spam email is going to the same folder and not a local one
  • Made sure that Junk filter option in Apple Mail’s preferences is disabled

Here is some additional information about the configuration of the Mac I am using to run SpamSieve:

  • macOS 10.15.3
  • Apple Mail 13.0
  • Google and Hotmail accounts configured as IMAP
  • Block Sender Apple Script installed and (sometimes) being used
  • Block Sender option in Apple Mail’s preferences enabled (but the block list is empty)

I am still experiencing disappearing emails including some that were not spam. Any additional tip?

Thank You,

Antonio

PD: I already checked the Gmail and Hotmail servers using the my browser (Chrome 79.0.3945.130) and the missing messages are not there either.

Could you explain this more? Do you mean that messages disappear after you train as spam or as good? Or at some other time?

That’s correct, however I see that you are using macOS 10.15, which contains several bugs that can unexpectedly delete messages when they are moved by a rule or other manual means. If you are one of the (relatively few) affected users, the bugs also occur when SpamSieve is not installed, but they can also be triggered by SpamSieve. That is, if dragging and dropping a message will make it disappear, asking SpamSieve to train it (with the training command set to move messages) will likely also make them disappear.

Do you mean that you turned off the SpamSieve rule on the other Mac? Does the problem occur when Mail is not running on that Mac?

One of the bugs is that messages can be deleted when moving them cross-account. If that’s the one affecting you, you would want to have multiple spam mailboxes, one for each account. That way, the Hotmail spam would be moved to the Hotmail Spam mailbox and the Gmail spam would be moved to the Gmail Spam mailbox, so that the messages always stay within the same account.

Thanks for your prompt reply. Following you will find my answers to your questions or comments and an additional question for you:

  1. Could you explain this more? Do you mean that messages disappear after you train as spam or as good? Or at some other time?

It happens days after I have trainned them as spam. I have one message from my son disappear and I don’t think that I did trained it as a spam but it might have by mistake.

  1. That’s correct, however I see that you are using macOS 10.15, which contains several bugs that can unexpectedly delete messages when they are moved by a rule or other manual means

It seems that I am one of the luck ones (see 4)

  1. Do you mean that you turned off the SpamSieve rule on the other Mac? Does the problem occur when Mail is not running on that Mac?

I uninstalled SpamSieve on the MacBook Pro that is not always on. The iMac is always on and always running Apple Mail and SpamSieve.

  1. One of the bugs is that messages can be deleted when moving them cross-account. If that’s the one affecting you, you would want to have multiple spam mailboxes, one for each account.

I think that you got it!!! I did consolidated all Spam messages in one Spam folder on my Hotmail account. I will try with different Spam folders.

Question, how do I achieve that? Just add an additional rule in Apple Mail and include an account criteria in both rules?

Thanks again and congratulations for this great solution for managing Spam. I will buy the license and recommend it to all my family and friends.

Best Regards,

Antonio

In that case, you may want to use the Change Settings command to tell SpamSieve not to move the trained spam messages or to move them to a Spam mailbox on the server (to keep them on the same account).

That’s right—see here.

Thank You!!!