C-Command Software Forum

SpamSieve no longer marking spam as read

I hadn’t had time to delve into it until today, but for at least the latest release the option to mark spam messages seems to have been broken.

I’ve run through the configuration tool a couple of times and double checked the plist and disabled rules/scripts (Server Junk Mail and Remote Training) that touch SpamSieve and the issue certainly appears to be in SpamSieve itself.

I’m on El Cap 10.11.6 with Apple Mail 9.3 (3124).
SpamSieve 2.9.26

Also running:
Mail Perspectives 1.5.3b1171
Mail Act-On 3.2.8 (build 2223)
MailTags 4.2.9 Build 4753
SignatureProfiler 1.9.14 (master: c7c1391)

Current Rules/Scripts (in order) are
SpamSieve Server Junk Mailbox
SpamSieve Remote Training
SpamSieve’s Normal Rule
A script that runs anything that survives the above through ClamAV

and a script to mark every message as read, which I have tried at various points in the chain.

There are also some Mail Act-On “rules” (really keyboard triggers) all of which do some combination of adding tags, changing colors, and filing into mailboxes. Nothing runs any additional scripts or does anything really complex.

Can probably tell from the mark everything read rule (and if you remember you helped me with the pMarkGoodMessagesRead switch that’s now in the Server Junk Mail script) that I’m not big on counter icons showing up with all of my mailboxes and trash constantly reporting unread messages is driving me a bit batty.

Regards,
Copper

So, to clarify, training a message as spam works (message changes color and moves to the Spam mailbox) but the message doesn’t get marked as read (even though you’ve chosen that option in Change Settings)?

Or are you talking about incoming spam messages being moved but not marked as read? In that case, you would need to modify the regular SpamSieve rule, and the marking is handled entirely by Mail. Do the messages in question have colored backgrounds?

Ugh. Incoming. I remember setting that up previously – ages ago, I’ve been using SpamSieve for a long, long time.But, sure enough, it was wasn’t in my current rule. No idea how that happened as it was working until some weeks ago.

Anyway, I’ve added it back in and a few tests show everything working as wanted/expected again.

Thank you for the time.