SpamSieve no longer sending spam to trash

I have been using Spamsieve for a long time, now on a Mac Studio running OS 14.2.1 Mac Mail and Spamsieve 3.0.3 as an extension.

I have the setting “Move it to the trash if the spam score is at least 70” checked and “Mark it as read” unchecked.

It had been working as expected with most spam messages being diverted directly to trash and still marked as unread.

I have not made any changes but now it is no longer diverting spam to the junk mailbox and they are marked as read. I have restarted the computer, quit both Mac Mail and Spamsieve and relaunched them but it has not solved the issue.

What is a solution to this issue???


Do the messages appear in SpamSieve’s Log window? My guess is that you may have a server filter that’s moving the messages to Junk and marking them as read before they get to your Mac and SpamSieve.

Thank you. To clarify, they are being flagged by SpamSieve as spam. I checked the log (I had never reviewed that before and it was helpful) and the spam is being predicted correctly. They are then colored by spamminess.

The issue is they are no longer being moved to the trash folder when they are predicted to be spam. And they are being marked as read in my inbox. That is not consistent with the settings I have set:

Please note this was all working fine up until yesterday and I am not aware of any changes that I made that would have affected it.

Are you using the Rescue Good Messages script? That doesn’t yet know how to follow the settings.

Since I don’t know what that is, I will say no :grinning:

This was successfully diverting the spammy messages to the trash up until this week.

Is there a way to read the log to see what it is doing with the message. In the Type column there are some icons after the “Predicted: Spam” words, what do these mean?

I should add that this has happened before and quitting Mail and Spamsieve and restarting them has resolved the issue.

The icons mean that these same messages were processed multiple times, both before and after the log entry shown. It’s not clear why that would be. Maybe Mail had trouble moving them. Please use the Save Diagnostic Report command in the Help menu and send me the report file, as described here.

Thank you for the support Michael. I have sent the diagnostic report via e-mail to you.

I did a manual filter of messages to see if that did anything, that would be why it shows the icons that it has been processed twice, once automatically after download from the server and then the one I initiated.

Thanks for the report. It looks like SpamSieve has been repeatedly trying to move the messages to the Trash, and Mail hasn’t been reporting any errors, but the messages are not moving. You might want to go to Settings ‣ Accounts ‣ Mailbox Behaviors and make sure that each account has a Trash mailbox selected that’s on the mail server.

You are correct that something has happened to my trash mailbox, but I am not aware of any changes I went and set the following:
Screenshot 2024-02-09 at 2.32.11 PM

I moved a couple of spam back into my inbox and did a manual filter and it seems to have worked. Not sure what has a happened to my trash mailbox. Do my settings look OK for an imap account now?

Looks like I received some spam that got diverted directly to the trash :+1:. It was still marked as read even though I have do not have the “Mark it as read” box checked???


It’s not clear why that would be. You could click here to enable some extra diagnostics to see whether SpamSieve is actually asking Mail to mark the messages as read (though I don’t see why it would be).

I did this and quit SpamSieve. I have received two messages that SpamSieve identified and they were both marked as spam, moved to trash and kept as unread! Not sure what happened there. I looked in the log and see lot of line items with type debug now. Will the debug continue to run???

The problems seem to have been fixed. Do you want any additional information for your information, as of now I seem to have SpamSieve working as I want.

Thank you again for the excellent support.

I’m glad to hear that it’s working now, though it’s a mystery what caused the change. You can click here to turn off the debug logging.