C-Command Software Forum

SpamSieve not applying Uncertain Junk category?

I’m trying out SpamSieve 2.7.2 and it’s been working well for me so far. I use it with the latest version of Entourage (12.1.5). The one problem I’m having is that mail that should be categorized as “Uncertain Junk” isn’t having that category applied and is remaining in my Exchange Inbox. (“Junk” mail is being categorized and is being moved.) I believe it should have been categorized as “Uncertain Junk” because of entries like this in the SpamSieve Log.log file:

Predicted: Spam (73)
Subject: Celebrate this Holiday Season with 15 handmade Cigars
From: HandmadeCigars@pliableskin.com
Identifier: 97vo7zODOoGUmriCo5UTcg==
Reason: P(spam)=1.000[0.500], bias=0.000, optin(1.000), 411(1.000), 33161(1.000), satisfaction(1.000), satisfaction(1.000), limit(0.001), S:15(0.999), limit(0.001), finest(0.999), minors(0.002), greater(0.998), greater(0.998), court(0.002), thompson(0.002), thompson(0.002)
Date: 2008-12-14 19:45:22 -0800

I didn’t change the threshold for “Uncertain Spam” from its default, so 70-90 should be “Uncertain Spam,” right?

When I first saw that this was happening, I found that no “Uncertain Junk” category had been created, so I created it manually after reading a response on this forum. However, newly received “Uncertain Spam” still remained in my Inbox. (I didn’t expect old “Uncertain Junk” messages to move.)

I’ve also run “SpamSieve - Change Settings” again and accepted the defaults to no apparent effect.

Can anyone suggest what I’m doing wrong, or what I need to do to fix this? Thanks!

Which category is being applied instead of “Uncertain Junk”?

In order for IMAP or Exchange messages to move to the Junk E-mail folder, you need to set up the “SpamSieve - Move Messages” rule as shown here.

The default is for for 50–75 to be considered uncertain.

None.

In order for IMAP or Exchange messages to move to the Junk E-mail folder, you need to set up the “SpamSieve - Move Messages” rule as shown here.

I did that when I first installed SpamSieve; I’ve attached a screenshot.

Any other ideas?

Please check the instructions again. A second rule called “SpamSieve - Move Messages” is needed for IMAP and Exchange messages.

Sorry, I seem to have posted the wrong screenshot. I have both a “SpamSieve - Move If Spam” and a “SpamSieve - Move Messages” rule. I’ve attached screenshots showing both.

Looking at the “SpamSieve - Move Messages” rule, I notice that it doesn’t have a criterion for “Category is Uncertain Junk.” Should I add one?

Regardless, though, SpamSieve does not seem to be assigning the “Uncertain Junk” category to messages that score in the corresponding range.

Yes. You also need to change it from all to any.

Let’s see what happens after you modify the rule. It’s possible that without that criterion some other rule (perhaps in the mailing list manager) would remove the “Uncertain Junk” category, making it look as though it hadn’t been assigned.

OK, done! I’ll report back on the results. Thank you!

Looks good! I just received spam email that scored a 75 and was properly filtered into my Junk E-mail folder. However, SpamSieve applied the Junk category to it, not the Uncertain Junk category. I don’t really care too much about that right now, but at some point it might be nice to be able to distinguish between the categories.

My mistake. If it’s set to 75, that means the score must be less than 75 to be considered uncertain.

Ah, OK. Well, I’ll keep watching for Uncertain Junk, then.

Thanks!

I received a couple of pieces of spam last night that were scored in the “Uncertain Junk” range by SpamSieve but not categorized, and hence not moved. Here’s one:

Predicted: Spam (73)
Subject: Your account was blocked!!
From: originated@themesclub.com
Identifier: fJnLYfvnvHrMKpVQ2T1WJQ==
Reason: P(spam)=1.000[0.501], bias=0.000, A:HERE(1.000), U:entry(1.000), U:spaces(1.000), U:cns(1.000), U:106(1.000), x-greylist:16(1.000), lost(0.000), lost(0.000), x-greylist:23(0.999), beginning(0.001), beginning(0.001), R:^br(0.999), S:account(0.999), x-greylist:302(0.998), unforgetable(0.998)
Date: 2008-12-16 08:03:35 -0800

Any thoughts on what I should do next?

Perhaps there was an error setting the category. Please select a test message in Entourage. Open the attached script in Script Editor, and then click the Run button. Does it change the category to “Uncertain Junk” or report an error?

It changed the category to “Uncertain Junk.”

Strange, then, that it isn’t working automatically. Could you send me your preferences file?

/Users/<username>/Library/Preferences/com.c-command.SpamSieve.plist

Sure thing, Michael. En route. Thanks.

The problem was due to a bug in SpamSieve, which will be fixed in the next version.

This is fixed in SpamSieve 2.7.3.