C-Command Software Forum

SpamSieve not honoring manual blocklist rule

I get a lot of spam that has “w4tch” in the subject each day. Every time I flag it as spam, yet I still get it. I then created a rule where the subject contains “w4tch”. SpamSieve never catches it, and the hit count remains 0 (obviously, it’s not catching it). What am I doing wrong? The rule seems simple enough that I don’t think I messed it up. I have ensured that the rule is enabled.

There may be a setup problem in your mail program, or you may have enabled another SpamSieve filter that has higher priority than the blocklist. Please check the log.

Fantastic. The message came from my address, which was overriding the rule. I’ve updated my preferences, so I should be all set. Thanks for the very speedy response!

I spoke too soon. I just got another email that “should have been” caught. The log reports that “Reason: sender <my@address> in address book” (same as before)

I had the “Exclude my addresses” checked, as the tooltip suggests to turn it on if spammers are sending messages from my own account. I also had it unchecked, and I get the same results either way.

Update: I just realized I have an entry in my Address Book that has all of my email addresses. I’m not sure if this is overriding the “exclude my addresses” option.

In order for Exclude my addresses to work, the address in question must be on your card (the one that says “me” over the photo) in Address Book. Also, sometimes it’s hard to tell, but it must be in an e-mail field on the card, not in a phone number field.

That doesn’t matter so long as the address is on the Me card.

The card was not flagged as the Me card. Thanks again.