C-Command Software Forum

SpamSieve not moving spam message

A few spam messages are getting though (no big deal, happens). When I use the File command Message->SpamSieve - train as spam however, nothing happens to the message, it remains in my inbox and not mark/moved as spam as I would expect (and normally happens). So far this has only happened twice.

Does SpamSieve’s log show either “Predicted” or “Trained: Spam” entries for those messages?

Log - email still won’t move out of inbox and into Spam mailbox…

Trained: Spam (Manual)
Subject: Re:
Identifier: i5s6kaCXbsw5QINxwXtMTQ==
Actions: added to Spam corpus (2026)
Date: 2011-06-30 06:42:52 -0700

Mistake: False Negative
Subject: Re:
Identifier: i5s6kaCXbsw5QINxwXtMTQ==
Classifier: Address Book
Score: 0
Date: 2011-06-30 06:42:57 -0700

Trained: Spam (Manual)
Subject: Credit Card Overdue
Identifier: oIVYSvlG3gnwHR7eVp1HpA==
Actions: added rule <From (address) Is Equal to "info19623@mailer-daemon.com"> to SpamSieve blocklist, added rule <From (name) Is Equal to “Notification robot”> to SpamSieve blocklist, added to Spam corpus (2027)
Date: 2011-06-30 06:44:13 -0700

Here’s a second one that won’t move out of the inbox:

Trained: Spam (Manual)
Subject: MaxGentleman Enlargement Pills
Identifier: Efy1BQD9BnPgRhx28Ck4AQ==
Actions: added rule <From (address) Is Equal to "pboj@oiia.com"> to SpamSieve blocklist, added to Spam corpus (2028)
Date: 2011-06-30 06:49:21 -0700

This indicates that the message did get trained as spam. Maybe it didn’t get moved to the Spam mailbox because your did not have a mailbox name (exactly) “Spam” under “On My Mac”. Or perhaps Mail tried to move the message and encountered an error—in which case it might be mentioned in the All Messages section of the Console application.

This indicates that SpamSieve thought the message was good because the sender was in your address book (and you’d configured SpamSieve to trust that).