C-Command Software Forum

Spamsieve Plug in is rejected by MacOS Monterey 12.13.1 - Mail Version 16.0 (3696.80.82.1.1)

Hello I am in trouble with SpamSieve 2.9.48 and MacOS Monterey 12.13.1 (registered version)
I got the message below : in French
Mail a désactivé les modules suivants :
SpamSieve.mailbundle
Contactez les éditeurs de ces modules pour en obtenir des versions compatibles avec Mail 16.0.
**In English : **
Mail has disabled the following modules:
SpamSieve.mailbundle
Contact the publishers of these modules to obtain versions compatible with Mail 16.0.
Some help would be welcome !!
Jean-Louis

Please see this page.

1 Like

Thanks for your help ! the problem has been fixed , when I disable SIP !!
1 - ( Commmand + R )
2- Terminal
3- " csrutil disable " (with no quotes) return ,
SIP is off …
RESTART

SpamSieve Mail plugin work again !
Best regards
Jean-Louis

I’m glad that worked for you. Just to be clear, if you disable SIP and delete the folder indicated, you should be able to re-enable SIP and still have it work. Or you can keep running with SIP disabled if you want.

I must have SIP disabeled to use SpamSieve , as soon as I re-enable SIP , the SpamSieve plug in is deleted by MacOS Monterey …
What do you mean by " if you disable SIP and delete the folder indicated, you should be able to re-enable SIP and still have it work " ? …

I’m referring to the instructions here where it suggests deleting the folder /Users/<username>/Library/Application Support/Mail/Plug-ins/. If that doesn’t help, there are also some other things you could try here.

Hello ,
I have followed very carefully all the instructions , and my SpamSieve plug in is rejected each time I set SIP « on » … !?
I have renamed the plug in folder « Plug -ins » to « Plug - ins Disabled » , however I didn’t delete the renamed Plug-in « Plug - ins Disabled » … I don’t know if I must do it absolutely ! ?
Thanks for your help !
Jean-Louis

Did you try deleting the folder? The next time Mail rejects the plug-in, please use the Save Diagnostic Report command in the Help menu and send me the report file, as described here.

No , I didn’t delete the folder , just rename it …