C-Command Software Forum

SpamSieve pop-up every time I open Mail

“Do you want the application “spamsieve.app” to accept incoming network connections?”

Is there a way to permanently allow the incoming network connection?

incoming network connection?

I think you are getting this message because your firewall is turned on. Go to system preferences/Security/Firewall and you can add SpamSieve to the applications that accept incoming connections.

I think this will normally happen automatically if you click Allow or if you have “Automatically allow signed software to receive incoming connections” checked in the Security & Privacy preferences pane.

An exception is if you have modified the SpamSieve application, e.g. to hide its Dock icon. Then Mac OS X will ask at every launch because it detects that SpamSieve’s code signature is invalid. The solution to this problem is to update the code signature.

That did it…copy/pasted ‘codesign -f -s - /Applications/SpamSieve.app’ into terminal and it’s all set now.

Thanks!

This extra step is no longer necessary with SpamSieve 2.9.1.