C-Command Software Forum

SpamSieve Public Beta and macOS 10.14 Mojave

When there’s a new version of the operating system, SpamSieve typically needs an update for compatibility with the new version of Apple Mail. Mail will present an error saying:

Mail has disabled the following plug-ins:

SpamSieve

Contact the makers of these plug-ins for versions that are compatible with Mail 12.0.

We make a public beta version of SpamSieve available for compatibility with the latest macOS beta:

The beta release notes are available in the Software Update window and also in the Version History section of the manual (in the Help menu).

We do not recommend using a macOS beta on your main Mac, as there may be bugs that we have not had time to, or cannot, work around. With that said, we do welcome bug reports so that we can investigate any bugs and report them to Apple or try to develop workarounds. Please submit any feedback or bug reports via e-mail, rather than posting here.

When the new version of macOS is finalized and released to everyone, we (usually within hours) test SpamSieve with the release version and finalize the new version of SpamSieve. The new version is announced on the SpamSieve mailing list, blog, and Twitter feed and becomes available via the Software Update… command. It’s best to update SpamSieve before updating macOS. To prevent macOS from updating itself without asking you, go to the App Store section of System Preferences and make sure that Install macOS updates is unchecked.

macOS 10.14 Mojave Compatibility

Currently, the SpamSieve beta is not compatible with the macOS 10.14 Mojave developer beta. I will post an update here when it is.

SpamSieve 2.9.32b3 is now available with preliminary support for macOS 10.14 Mojave.

Not working

This doesn’t appear to be working. Having installed it, none of the menu options I’d expect to see are available in Mail.

Strike that; fixed it (plugin wasn’t activated in Mail)

Manage Plug-ins
I have macOS 10.14 Beta (18A293u), Mail 12.0 (3445.100.9.7) and SpamSieve 2.9.32b3 running on a test Mac. SpamSieve is working as expected.

Whenver the computer requires a restart and Mail is launched, the Manage Plug-ins option is turned off which means SpamSieve doesn’t load and Mail processes everything based upon the first Rule and everything goes to the Spam folder. I have no other plug-ins currently with which to test.

Is it my setup only or have others experienced this? If the latter, I’ll report it as a bug. If the former, I need to figure out why?

Thank you,

Bruce

From what I’ve seen, Mail disables all plug-ins if the Mac crashes. Otherwise, they should stay enabled across a restart.

Well, that makes some sense but it certainly messes up incoming e-mail since the SpamSieve rule is the first one and I don’t see any way to set Mail to NOT check e-mail on startup. I’ve changed the time to check from Automatically to 5 minutes in the hopes that gives me time to set turn on the plug-in and make a difference.

Thank you,

Bruce

Yeah, I’m not sure what can be done about this at this point, given the way Mail works. I’m open to suggestions. I can try to have SpamSieve detect that the plug-in has been disabled and remind you to re-enable it. But (unless you disable Wi-Fi) I don’t think you can actually get to the Mail dialog to re-enable the plug-in before it does its automatic check for new mail.

Are you getting a lot of crashes with Mojave, and if so do you know what’s causing them?

I’ll have some time this week to give it a try.

If I don’t access the test computer for awhile (say, overnight), I’ll come back to a black screen from which there is no recovery other than restarting the computer.

It might be related to Screens Connect. Numerous messages in the logs. Found that there were updates not necessarily related to Mojave but I’ll see if it makes any difference.

Thank you,

Bruce

Turns out that it was Screens Connect. I updated and disabled it but will try it again this weekend.

Bruce

SpamSieve 2.9.32b3 and macOS 10.14 Beta 2
Updated the beta of Mojave this morning. So, now running macOS 10.4 (18A314h), Mail 12.0 (3445.100.13.1) and SpamSieve 2.9.32b3. Prior to the update, SpamSieve was marking the spam properly (according to the SpamSieve log). However, the rules don’t seem to be working because my Inbox is filled with numerous spam e-mails marked as Unread with text set to Gold as if Mail’s Junk Mail Filter was processing them. None have been processed by any of the rules.

The Manage Plug-ins is set on for SpamSieve, all of the rules are the same as before the update and all are correct.

I’m not sure where else to look for the resolution. Are you seeing a similar issue? If so, I will wait for an update. If not, what information can I send to you?

Thank you,

Bruce

I’m not seeing that issue here. Could you send in a diagnostic report?

I seem to be stuck. I installed Mojave, which of course “broke” SpamSieve, which is now sending all mail to the Spam mailbox. I’ve read your instructions for dealing with this at https://c-command.com/spamsieve/help/why-don-t-i-see-the-spa, but nothing is working.

I’ve signed up for your public beta, but nothing is triggering the update. Is there a direct link to download the beta builds?

UPDATE: OK. I was able to “force” installation by downloading the current build (non beta) and replacing the newer app with that one. Then, upon launching it, I was prompted to download and install the beta update, which I did. But Mail still isn’t displaying any SpamSieve commands in the Message menu. I’ve performed the recommended steps (including restarting the Mac) several times, to no avail.

All messages are going to the Spam folder. Any suggestions would be greatly appreciated.

If you’ve turned off automatic updates, you can check for updates manually from the Software Update command in the SpamSieve menu.

Thanks for the reply, but I haven’t turned off automatic updates. I wonder if you missed the rest of my message. I cannot access the SpamSieve menu at all. That’s the problem.

Have you looked in Mail’s preferences under General
at the bottom click “manage plug-ins”
and click the box for SpamSieve

I didn’t respond to that part because once you have the beta version, the instructions that you linked to should work. Your original message said you couldn’t download the beta, so that seemed to be the core problem.

If you didn’t have the beta before, why was the current release version older than what you had installed?

Do you mean the SpamSieve menu or Mail’s Message menu? You wrote “SpamSieve” above, but the page that you linked to was about the Message menu.

For the SpamSieve menu, you would need to show the Dock icon.

For the Message menu, you would need to install SpamSieve’s plug-in. In order to successfully do this you need to give SpamSieve access to Mail’s Application Data in System Preferences and also enable the SpamSieve plug-in in Mail’s General preferences. It should automatically explain this to you when you install the plug-in.

That did it! Thanks.

(The instructions to which I linked, above, don’t mention that item in Mail’s preferences. Perhaps the developer will consider adding that step to the instructions.)

I’m working on that, however currently the app itself shows you the instructions (if you are running macOS 10.14) after you successfully install the plug-in. The current wording is:

Make sure the SpamSieve plug-in for Mail is enabled.

SpamSieve installed its Apple Mail plug-in. Please check that it’s enabled:

  1. Quit Mail if it’s open.
  1. Launch Mail and choose Preferences… from the Mail menu.
  1. Click on the General tab.
  1. Click the “Manage Plug-ins…” button at the bottom of the window.
  1. Make sure that “SpamSieve” is checked.
  1. Click “Apply and Restart Mail”.
  1. If you haven’t already, you should now follow the instructions in the “Setting Up Apple Mail” section of the manual for creating a SpamSieve rule in Mail.

Also, the first time you install the plug-in, you should get an alert that says:

SpamSieve needs access to Mail’s data.

Please allow SpamSieve to install its Apple Mail plug-in and communicate with Mail. To do this:

  1. Go to the “Security & Privacy” pane of System Preferences and click on the Privacy tab.
  1. Scroll down and click on “Application Data”.
  1. If the lock button in the lower left corner of the window is locked, click on it, enter your Mac’s login password, and click Unlock so that you are allowed to make changes.
  1. Click the + button and choose SpamSieve from your Applications folder. SpamSieve should now appear in the list as checked.
  1. Click the Later button in System Preferences.
  1. After reading the rest of this step, click the OK button below to quit SpamSieve. Then relaunch SpamSieve.

I did have the beta. But since no SpamSieve items were appearing in Mail’s Message menu, I was attempting to install a fresh copy. After posting here, it occurred to me to install the non-beta, then allow it to prompt me to upgrade.

I’m sorry for my choice of words. I meant that I could not see any SpamSieve items in the Message menu. I was unaware of a separate SpamSieve menu, accessible via the dock. Had I known about that, I would have been careful to differentiate.

Thanks.