C-Command Software Forum

spamsieve public beta with mac os 10.12.4 BuildVersion: 16E195

I’m a visually impaired user who is using spamsieve. I love it, except with 10.12.4 it crashes mail. I tried a factory reset of mail and it worked for all of about 5 minutes. I will upload and link to my sys diag file so you all can see what’s going on. It seems that a hotkey or something is conflicting even though I’m not pressing any keys to trigger the crash. I won’t be near my computer when this happens or I can be just in another app when I notice mail crashing. Here is the link to my sys diagnose file

Thanks.

It does not look like SpamSieve was doing anything at the times of these crashes, and they don’t match any crashes that I’ve seen before. Please try removing any other Mail plug-ins (such as MailButler) and see whether the problem still occurs.

Actually that didn’t work. I uninstalled mail butler, but the mail appstill crashed. I even did a reinstall of spamsieve, I think. I can’t remember now. Here is the new sys diagnose file.

The file is uploading as of this writing but it should be done by the time I send this, if not try again i about 2 minutes.

The key error seems to be:

*** Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘Trying to create a mailbox operation without a mailbox name’

This looks like a Mail bug that’s not related to SpamSieve. Does the problem still occur if you uncheck the SpamSieve rule in Mail? Do you have any Mail rules besides SpamSieve that move messages to different mailboxes?

Separately, it looks like Mail may be having trouble launching SpamSieve. Are you able to use the SpamSieve training commands in Mail?

I am able to use the training commands, yes. I do have other rules, however the folders do indeed exist. I did report this to apple a while back right around 10.12.2 beta but they said it was a third party plugging so I’ve ben trying to work out if it is mail butler, which I thought it was, or spamsieve which it looks like it should not be.
I even did a clean install of the system but it still happens as soon as I install these two plugins.

thanks.

Have you tried unchecking all of your rules?