C-Command Software Forum

SpamSieve tagging all mail as spam

SpamSieve has been my indispensable second line of defense for many years. My first line has been the spamfilter we use at our company, which was SpamAssassin, but which we recently transitioned to mailroute.net.

I was attempting to use SpamSieve to “teach” mailroute.net about spam that sneaks by it by forwarding the message to their abuse report email. However, I noticed that the SpamSieve mail rule was sending every message.

I then changed the rule so that it simply changed the background of the message to gray. When I applied the rule to my inbox every message had the gray background.

I reinstalled my SpamSieve Apple Mail plug-in and checked the SpamSieve mail rule.

The mail rule is “If any of the following conditions are met: Message Type is Mail, Perform the following actions: Set Color of background Gray”.

I didn’t change anything else. Now all messages are tagged as spam by SpamSieve.

Any clues?

Thanks,

Dave

SpamSieve sets the message colors itself, so you should not add actions to the SpamSieve rule that change the message color. Due to the way coloring rules work, Mail will change the colors of all messages, even ones that SpamSieve didn’t think were spam.

In my testing, forwarding actions do not share this problem, but in any case I think the best way to teach a server-side filter is to move the messages into its IMAP folder on the server. Forwarding is less desirable because it changes the message content.

Thanks for the quick response, Michael!

I changed the rule so that it moved spam messages to a Spam folder, however it is moving all messages that come in.

I’m wondering if mailroute.net modifies the headers in such a way that SpamSieve things everything is spam?

(I’d paste the message header in here, but I’m worried the forum, just like everything else, is scraped by spambots.)

Best,

Dave

There may be a setup problem. Does the log say that SpamSieve thought these messages were spam?

There is no magic header that makes SpamSieve think everything is spam.

Michael,

I looked at the log, which has a lot of entries in the past.

There are no entries for today, but I’m sure that it moved 2 messages to the “Spam” filter that I set up earlier.

So the mail rule seems to be applying the rule to everything, but SpamSieve isn’t logging anything about it. I wonder if the rule isn’t invoking SpamSieve?

I did re-install it earlier today, before the behavior noted above.

Thanks,

Dave

Please see this page.

Michael,

  1. Make sure that you have installed SpamSieve’s Apple Mail plug-in and that you see the training commands in Mail’s Message menu.

**Check. Fresh install. SpamSieve - Change Settings, SpamSieve - Train as Good, SpamSieve - Train as Spam are all present.
**
2. Make sure that you’ve disabled Mail’s built-in junk mail filter.

Check.

  1. Make sure that the only spam/junk rule that you have in Mail’s preferences is SpamSieve.

Check.

  1. The name of the SpamSieve rule in Apple Mail must begin with “SpamSieve”. Make sure that there are no leading spaces in the name. If the rule name does not begin with “SpamSieve”, Mail will move every message to the Spam mailbox without even showing the messages to SpamSieve.

Name is exactly SpamSieve.

Thanks,

Dave

Did you remove the coloring action like I suggested? The rule should look exactly like the one shown here.

Michael,

Yes, my rule is basically the same as yours. I included a screen shot. Because it was putting everything into the Spam folder, I disable the rule, and deleted the Spam folder - that is why it now says “No mailbox selected”.

I can go back and recreate the Spam folder and re-enable the rule. I’ve tried restarting Mail and reinstalling SpamSieve. I’m wondering if a full reboot of my Mac might help.

Thanks,

Dave

I suggest that you delete the rule entirely and create a new one exactly as shown.

OK, I created the rule exactly as shown and re-enabled it. All messages are now tagged as Spam and wind up in the Spam folder.

Any other ideas?

Thanks,

Dave

Could you clarify what you mean by “tagged as Spam”? What does SpamSieve’s log say about these messages?

What I mean is, every incoming mail message is moved to folder “Spam”.

The SpamSieve log says absolutely nothing since it’s last launch message:

=====================================================================
Launched: 2.8.3
Date: 2010-10-09 11:42:51 -0700

It’s as if the SpamSieve rule were being interpreted literally, without SpamSieve’s intervention.

Thanks,

Dave

OK, so there is no color change, and Mail does not show them marked as junk messages?

Please e-mail me the file:

/Users/<username>/Library/Mail/MessageRules.plist

so that I can see how you have things set up.

Michael,

OK - sent.

Thanks,

Dave

According to the file that you sent, your rule name is “ SpamSieve”. It should help to delete the leading space.

Michael,

Oh! You’re right. I deleted the leading space - I’m so sorry I didn’t see it.

Thanks for your jump-right-on-it awesome support. My second line of defense appears to have been restored.

Best,

Dave