SpamSieve worked on one computer, moved to another and now it doesn't


I have read multiple forum posts and the help topics and manual, but I still can’t figure this out… I started using SpamSieve 3.0.3 on a Mac running 14.4.1 and it worked great. Everything worked as expected. However, it was a laptop and I decided I’d rather have it running on a desktop computer that is always on. This desktop Mac is on 12.7.4. Not sure if that has any bearing on the issue, but I think it should be compatible.
I moved the folder in Application Support as well as the .plist file in Preferences. I then installed SpamSieve on the desktop. I made sure all the permissions (like full disk access) were set correctly, but now I’m getting “Check the setup to make sure inbox messages can be filtered.” and “Move some old messages out of a large mailbox so it can be filtered.”
I have the EXACT same accounts on the desktop Mac as I did on the laptop where it was working perfectly fine. The main account does have around 17,000 messages, but as I mentioned, it was filtering spam on the laptop before moving over. I even tried setting the MailboxesOutlineRedMessageCountThreshold to a higher value. That did change the mailbox from red to orange, but as I said, it didn’t require that on the laptop computer.
Now, none of the incoming messages are being filtered and the log shows “-12,345” because it has too many messages. Not sure if intended or not, but new messages ARE being flagged with an orange flag, but NOT being marked as spam and moved to the spam folder.
Any suggestions?

You are encountering a macOS bug that affects SpamSieve’s Mail extension. SpamSieve’s built-in workaround for the bug can only handle large inboxes on macOS 13 and later. That is why you are getting those errors.

Since you are on macOS 12, I recommend switching to the plug-in setup, which avoids the bug entirely.

Thanks for your quick reply. It looks like enabling the plug-in instead of using the extension works!
I had one followup question: With the extension (not plug-in) enabled, there is an option to “Move it to the Trash if the spam score is at least…” but it is greyed out when using the plug-in. Is there a rule I could set up that would accomplish the same thing? Essentially, I would like all “really spammy” messages to automatically be trashed, but those that are on the fence still go to the Junk folder. Is this possible?

Yes, please see Example 1 here.

Thanks so much for your help!