C-Command Software Forum

SpamSieve Works Only Intermittently

I’m running SpamSieve as a free trial on Outlook for Mac 2011 (v14.4) on Mac OS X 10.9.2.
Everything is setup properly, I’ve trained it on Good and Spam emails, and my Junk E-Mail box fills up nicely. Stats pasted below.
I retrieve email on an IMAP account on my desktop iMac plus an iPhone and iPad - all of which are set up the same way for my IMAP email account.
But …
The Junk E-Mail folder only finds email when I’m sitting in front of it and stops during the day.
I have one very persistent spammer that sends dozens of messages a day. All day long, I’m still deleting them off the other devices, but I would expect that my desktop running SpamSieve would catch more emails during the day. The whole reason for SpamSieve is so I DON’T have to delete emails all day long on any device, right?
For example, my Junk E-Mail folder added a few new spam emails while I was sitting at the desktop early this morning. And it still collected a few emails through 10:51am, but the next one in the Junk Email folder is at 7:22pm. And I’ve been getting spam all day on my other devices.
Are there settings to adjust to assure that SpamSieve is faithfully working 24/7 on my behalf?
Please advise, and thank you.

Filtered Mail
140 Good Messages
72 Spam Messages (34%)
14 Spam Messages Per Day

SpamSieve Accuracy
8 False Positives
14 False Negatives (64%)
89.6% Correct

Corpus
100 Good Messages
73 Spam Messages (42%)
13,332 Total Words

Rules
51 Blocklist Rules
179 Whitelist Rules

Showing Statistics Since
4/27/14, 9:01 PM

There’s nothing special to do with SpamSieve. It’s just a matter of making sure Outlook is set to check for mail. You can adjust this via Tools > Run Schedule > Edit Schedules…. Also, make sure that you Mac isn’t set to go to sleep.

Now Setting up Outlook Drone

Thank you for the response.

I think I’ve solved for the ‘go to sleep’ problem. In Energy Saver settings, I’ve checked every box including ‘Prevent computer from sleeping automatically when the display is off’, ‘Wake for network access’ and ‘Enable Power Nap’.

Now I’m trying to solve for multiple email clients: iMac desktop, iPad and iPhone for the same IMAP account that’s set up on all three devices. Spam is still appearing on the other devices, so I think I need to set up Outlook Drone. But I’m running into two issues, as follows:

  1. Your instructions say ‘Make sure that each of your accounts has its own Junk E-mail mailbox. This can be configured by going to the Accounts section of Outlook’s preferences and clicking on Advanced… and then Folders.’ When doing this, the Junk section in the Folders tab has chosen Spam (Server) from the drop down. All the other choices are on the computer. I think this setting is OK. Is that so?

  2. The next instruction poses a problem. It says ‘If you have a single mail account, follow the normal SpamSieve setup procedure in the Setting Up Outlook section. When choosing the folder in the SpamSieve - Move Messages rule, be sure to choose the Junk E-mail folder on the server (not On My Computer).’ However, in the ‘Do the following’ section of the rule setup, the default choice is Junk E-mail (On My Computer) and I can’t find a ‘Choose Folder’ option for ‘Junk’ or ‘Spam’ from the Server. In fact, every choice via the Search function is for an ‘on my computer’ option; none are from the Server. So I can’t complete the instructions for Outlook Drone. Please help.

Thank you!

You don’t need the drone setup to prevent the spam from appearing on the other devices. The drone is only for training SpamSieve from the other devices. Even if you want to do that, I recommend getting the regular setup working first. Maybe you need to increase the frequency with which Outlook checks for new mail. You can’t entirely prevent the spam from appearing in an iOS inbox, but it should disappear when Outlook checks for mail and moves it to the Junk E-mail folder.

Yes, you want the server folder.

If you type “Junk” or “Spam” in the “Choose Folder” sheet, it should show additional folders with those names.