C-Command Software Forum

SpamSieve would not accept my own emails, being HTML emails

SpamSieve is a great utility but certain kinds of emails, even if the sender’s name and email address is in my Conatcts – it still regards as SPAM and refuses to “accept” it into my Mail program. What’s even more annoying, I go to my ISP’s website to check my mail, I find the specific email I’m expecting, I forward it to myself (from my own address to my own address) — still SpamSieve would insist refusing it to land in my Mail window…

I noticed what’s common to those “refused” emails, is them being HTML emails, with remote images… I guess SpamSieve is refusing those emails for protection of my privacy and/or security, but if I use my own address to forward such email to myself, wouldn’t it tell SpamSieve to allow it? Is there a way to change SpamSieve’s setting to allow it?

…Thanks much!..

If the sender address is properly entered into your address book (the Contacts app) and you have Use Mac OS X Address Book checked in the preferences, SpamSieve will classify the message as good 100% of the time. So this sounds like a problem with your mail server’s filter or other rules, rather than with SpamSieve. You can check for sure by opening SpamSieve’s log and seeing whether it says “Predicted: Spam” for the messages in question.

In the standard configuration, with Exclude my addresses checked, messages that you send to yourself are not guaranteed to be classified as good. This is because it is common for spammers to send you spam from your own address. If you want to be sure that a message will get through, you could create a whitelist rule that looks for a special word in the subject or body. However, in this case, the messages are probably not being moved to the Spam mailbox by SpamSieve, anyway, so that wouldn’t help.

You don’t have to guess. You can see exactly what SpamSieve is doing (or not doing) by looking at the log.

…Still, a friend sent me an Evite today, which never showed up in my Mail program, but at least this time, when (again, going to my ISP server) I forwarded it to myself – this time I got it…

…Any clue how I can make it work the first time?

Please see the What information should I include when I report a problem? page and e-mail the requested information so that I can help you further.

Thanks for sending me the additional information. The problem is that you have not set up the SpamSieve rule in Apple Mail as shown in the manual. Instead, you have two SpamSieve rules, neither of which is correct. You have it set up so that Mail deletes suspected spam messages before you can look at them. This means that you won’t be able to correct the mistakes, so SpamSieve will never be able to learn when it has made a mistake; it will learn incorrect information and the accuracy will get worse and worse. Here’s what I suggest:

  1. Delete both SpamSieve rules in Mail, as well as any other rules you’ve created that delete messages or move them to the Spam mailbox.
  2. Go to SpamSieve’s Filter menu and choose Reset Corpus; this will get rid of the incorrect information that SpamSieve has learned.
  3. Follow the Setting Up Apple Mail instructions to create the proper SpamSieve rule.
  4. Follow the Do an Initial Training instructions to retrain SpamSieve with correct information.
  5. If SpamSieve makes a mistake, use the “Train as Good” or “Train as Spam” command to correct it.
  6. There may be additional problems with your setup. If, after the above, you’re still seeing problems with messages from senders in your address book, please send in your log file.

Thanks so much… I did what you suggested… Time will tell…