C-Command Software Forum

Sparsebundle cannot be mounted

I have been asked to make changes to an old Final Cut Pro X project that was created by a now defunct company. The project is inside a sparsebundle which, I have been told, was most likely created with DropDMG. The problem is that I can’t mount the sparsebundle. I get an error message that the image is not recognized. I have tried to open it with the Disk Utillity but I only get this status message: Disk Write Status : Not mounted, Read-only.

When I check permissions on the sparsebundle it’s both read and write. Is there any way to open this bundle or is it irreparable?

Many thanks.

Have you tried using DropDMG’s Verify Image… feature?

Have you tried restarting the Mac? (I’ve seen lots of cases where something in the OS was messed up and restarting really did help images to mount.)

However, it sounds like the disk image may be damaged. Do you know how it was stored and transported? For example, older versions of Dropbox would corrupt sparsebundle files. Regular .dmg files are more impervious to network transport and foreign filesystems.

The sparebundle was indeed damaged. When I opened the package the three support files were all missing, only the bands folder was present. I downloaded DropDMG and created a dummy sparsebundle with the same name and size as the original. I copied the three support files to the damaged sparsebundle and it immediately mounted. I ran a repair on it and now it seems to be working fine. Some files could not be repaired but fortunately they can easily be replaced. So far so good.

That’s what I was going to suggest next. It often works, although I recommend working on a copy of the damaged sparsebundle to be safe.