C-Command Software Forum

SS *sometimes* works/IMAP

Hi Everyone -

I switched my accounts from POP to IMAP so that I could receive mail on my iphone. Before I did the switch, SS was working great.

Now, it works some of the time. I can’t figure out if the problem is SS or Apple Mail. It seems more often than not I am quitting Mail/SS and restarting them to get Mail to download the latest mail. For example, I’ll see mail on the iPhone, but Mail doesn’t download it by clicking “Get Mail”, or synchronizing folders. So I have to quit/restart Mail to get it to download.

SS will work sometimes, but other times I’ll see a heap of spam get through. Sometimes, quitting Mail/SS and restarting them will cause the spam to disappear (as if it got tagged but not moved). Other times, it just ignores it.

I am really confused on this, because I can look in the Spam folder and see it processing mail messages. But the combination of Mail not downloading the latest IMAP headers/SS sometimes working is confusing me! :slight_smile:

If anyone can point me in a direction of things to try, that would be great! Here are the specs:

IMAP (plus 2 POP accounts, and .Mac)
Mac Pro Dual 3 Ghz
SS 2.64
SS Rule is active, and is the top rule

Thank you!!!

Eric

First you could temporarily disable the SpamSieve rule by unchecking it in Mail’s preferences. This will let you make sure that everything is working correctly in Mail itself. If it’s not, then I wouldn’t expect it to work properly with SpamSieve.

Second, you could try creating a new rule at the top of the list that moves every message to another folder. This would let you verify that the rules are being applied to all the incoming messages.

Ok, as a follow up to this posting, it looks like the problem is related to using an iPhone to connect to IMAP while trying to do the same with Mail.app. The iPhone appears to lock the account and mail.app can’t get past that.

The quick solution (and it appears to be working for me so far) is to turn off automatic checking of mail on the iPhone and set it to “Manual”.

You can read more about it at:

http://joemaller.com/2007/07/05/iphone-vs-apple-mail/

It also mentions installing IMAP-IDLE, but I still needed to switch off auto check on the iphone for Mail/SS to work.

Eric