C-Command Software Forum

Starting to get SPAM (UNread) in Mail's Junk mailbox

Back in December, I found a thread where you mentioned using your ‘Apple Mail - Server Junk Mailbox script’. I edited it for my two IMAP accounts and added the Rule as instructed. It has worked well… until a week ago. I have started getting messages in the Mail Junk mailbox again, still marked as UNread. (Apple’s Junk filtering is unchecked/disabled, Junk Mailbox SpamSieve is first item in Rules, SpamSieve is second; OS X 10.9.5, Mail v. 7.3 (1878.6)) The script works correctly if I select any of the messages in the Junk mailbox and run it with “Apply Rules”.

The messages are from one of my IMAP accounts (Hostgator) that are forwarded to another IMAP account (iCloud). I will disable that forwarding and see if that makes any difference.

Any other suggestions?

Thanks!

The script only works automatically when you receive new messages in the inbox.

Uhmn… not to put too fine a point on it… How do I keep Mail from putting these in the Junk box? I won’t even worry about how they are marked or not… :wink:

Or, are you saying that Mail is simply following the “stamp” put on a message by some server? :head-bash: I’ll look at Hostgator’s cPanel to see if there are any control over that, but I don’t think Apple has any setting for its service.

I’m just confused that I didn’t see this for several weeks, now I am. Maybe it’s a late “Year 2000” problem! HA! :-0 It’s not a major problem, just irritating, probably like answering picky-ticky questions of [some] users? ;+)

Mail is not putting them in the Junk mailbox. A server filter is doing that before Mail even sees the messages.

Correct: Apple removed the feature to turn off its server junk filter. (It also deletes some messages without even putting them in the Junk mailbox. So I do not recommend using iCloud mail.)