C-Command Software Forum

Stuck scanning for new files

EagleFiler 1.8.4, macOS 10.14.1

I’m about two weeks into the trial and have seemingly run into a problem. This morning I set up a profile for my ScanSnap to put scanned documents directly into the ‘To Import’ folder. This seemed to work ok and there is a pdf in the folder. However, it has not been imported. After stumbling around a bit (and probably doing more damage than good), I started ‘File --> Scan for New Files’ and have been staring at that for a couple of hours now. After about an hour I tried to cancel that in the Activity screen but that doesn’t seem to work either and I’m sort of stuck. EF doesn’t want to restart while a library operation is in progress and I don’t know how to stop it. I’ve archive about 16K emails as mailbox files; outside of that there are fewer than 100 documents in the library. Any suggestions would be appreciated.

Thanks,

/bob

Sometimes an app that creates a PDF file leaves the file open. EagleFiler, for data integrity reasons, does not try to import open files in the To Import folder because typically when a file is open that means it’s in the process of being saved (i.e. still changing). Quitting the app that is creating the file or restarting your Mac should close the file, and then EagleFiler will import it.

“Scan for New Files” does not check whether the files are open. It just imports everything that’s already in EagleFiler’s Files folder, assuming that you know what you are doing.

Any idea why it is taking so long? How many files did you add to the Files folder before doing Scan for New Files? Which items are shown in the Activity window, and which one did you try to cancel? Does it say that it’s canceling?

Ok, the file in question was created by the ScanSnap Home app. I just quit the app but EF is still stuck in the cancel condition. The Activity window shows “EF: scanning for new files” and “canceling” below that.

Yep, that’s kind of what I thought; just trying to make something happen by trying that.

No idea; aren’t you suppose to tell me that :). I’m pretty sure I’ve closed and opened the library since I archived all the email so the total number of new files has to be less than 100. It’s been in this state for about 8 hours now so I think I’ll reboot and see where that takes me.

solved - not sure how …
Ok, I was able to Force Quit EF then reopen it and my test library. It came up fine and imported the pdf from the “To Import” folder. Just for fun, I started a File --> Scan for New Files and it acted as if there weren’t any which is actually correct. Everything seems to be working now but I still don’t know what I did to hang it up. I took a screenshot of the Activity window when it was hung if you’d like to see it.

Back to regularly scheduled testing. Oh, and despite this incident, I think this is going to be fine for my use case.

Thanks,

/bob

I’m not sure what’s going on there, as scanning for new files should be quick to cancel (and quick to complete, in the first place). If it happens again, you could record a sample so I can see why it’s stuck.

I thought there would probably be something obvious in the Activity window, or that perhaps you had initiated a large operation, but apparently not this time.

Sure, might as well send it to eaglefiler@c-command.com in case there’s something that jumps out to me as unusual. Thanks.