C-Command Software Forum

Suddenly getting error "The operation couldn’t be completed. (OSStatus error -1712.)"

I have made a lot of .dmgs of one particular program under development. This is a relatively small program about 15Mb. The latest version of the program runs perfectly well on my iMac using Yosemite 10.10.2, but when I try to drop the program file onto the dropDMG window as I have before, dropDMG starts and creates a temporary file, but after a long time (perhaps 10 minutes) I get the error shown above. This happens every time. I don’t believe I have changed the configuration file at all. I have tried reloading dropDMG but it had no effect. It is possible that I have not tried to create a .dmg since the OSX update to 10.10.2

Is there anything I can do?

PS I notice on searching the forum that this error did come up in the context of Automator way back, but it was supposed to be fixed long before the version of dropDMG I’m using, 3.2.6

Does your disk image have a layout? If so, does setting it to None in the configuration help? Does it help to boot your Mac in safe mode?

Got it working again, but…
Actually I just got the thing working by binning all the bits in the Applications Support area for dropDMG that I had created - the layout etc. Then I could make a .dmg, so these files may perhaps have become corrupt. However, although I can now create a .dmg with a background, I can’t put the icon for my program in the place that I set it to in the layout. It looks fine in the window in dropDMG, but it always ends up in the top left hand corner of the layout when the installer is run. This did not happen before, so I am still confused. Maybe I should trash even more stuff from the Applications Support area.

Having got it to work again, I tried to put in a custom volume icon (I think I know what this means, anyway it was a well-formed Mac icon) and it failed in the same way as before. After that, I tried setting the layout to “None” as you suggested. It did produce a dmg, although not really acceptable without a background, and anyway the installation process seemed to hang with the Spinning Pizza of Death and the Finder stopped responding.

I have never started my Mac in Safe Mode, so before entering that unknown territory, I think I’ll just restart it and see if that does anything.

Yes, restart solved it for me, at least this time. No other app was affected and quite a few were running, which suggests that dropDMG has some special requirements which can be disturbed somehow. I noticed also that switching between applications using cmd-tab didn’t work with dropDMG - the program’s windows did not appear when it was selected. This issue also disappeared with the restart. Maybe not relevant.

So, thanks for your help. I think restart, and possibly trashing some of the program’s parameters, got be back on solid ground.

I highly doubt that that was the cause of the problem. I have never seen those files get corrupted, and if they were DropDMG would report that it wasn’t able to read them.

This happens when the file in your layout does not have the same name as the file in the folder that you’re dropping onto DropDMG.

Meaning the error -1712?

What do you mean by “installation process”? Do you mean when you double-clicked the finished .dmg file?

DropDMG has to talk to the Finder to set up the disk image’s layout. The error -1712 means that DropDMG asked the Finder to do something and, a minute later, the Finder still had not responded. This should never happen, but of course the Finder is central to a Mac system and so there are many possible things that can interact with it and mess it up. That’s why I suggested the safe boot.

I’ve not heard any other reports of that. It would seem to indicate that something else was messed up on your system.

Thanks for those comprehensive replies. I think with your advice and a few restarts I will be able to do everything I want to do.

Just to clarify, by “installation process”, yes I do mean double-clicking on the finished .dmg file.

Thanks again.

OK. That part is handled by the OS disk image mounter. DropDMG is not involved.