C-Command Software Forum

Super slow when running AppleScript

For weeks, I kept having Apple Mail slow to a crawl, such that I could only type about one character per second, if at all. Then it would go back to normal after about a minute. It turned out this was when the Move if SpamSieve Spam AppleScript was running. I disabled that rule, and no more slowdowns. Of course no SpamSieve filtering either.

Also, for a while now, email identified as spam was not being moved to the spam/junk folder, it stayed in the in box. I went through a troubleshooting page and tried four or five things (that was last year sometime) to no avail.

I’m on 10.15.7, running 2 G Suite and one iCloud account. Admittedly I am a terrible email filer (currently 8000 messages in the 3 inboxes, which I clear out every year or two). SpamSieve worked great for many years (at least 14) before this. Any suggestions?

The Move If Spam script is indeed slower than SpamSieve’s plug-in based filtering, so I recommend using the plug-in if possible.

Do you mean the message doesn’t move when you choose SpamSieve - Train as Spam from the menu? Does it change color?

Right, when I choose SpamSieve - Train as Spam from the from the menu, the message stays in the (Gmail) in box. The background of the row (classic table view) turns color and Apple’s “You marked this message as Junk Mail [Not Junk][Move to Junk]” shows in a yellow bar at the top of the message view. A Trained: Spam (Manual) log entry is created.

This is with the basic “every Message to mailbox Spam” (on my Mac folder) rule enabled. Previously I used 3 rules for my 3 accounts and put some accounts’ spam in the account’s server Junk folder. But those rules are disabled now.

Clarification: the background of the row turns gray.

Update: I think moving is working on all accounts now. I turned Auto-Expunge off on the two Gmail accounts, and ran through the SpamSieve Change Settings, where I found I must have set the Spam folder name to “Junk” (when I was doing on-server spam folders). Now it’s back to “Spam” consistent with the basic SpamSieve rule.

That should be good enough for now. Thanks!

1 Like