C-Command Software Forum

Sync Mail Before Import to EF

I’m new both to archiving mail and EagleFiler. The process of importing mailboxes wholesale from Thunderbird to EF has been painless.

But behavior in Thunderbrid was set to the default, automatic download of images was set to off, i.e. not to download images. So now I want to back up numerous mail boxes with thousands of incomplete emails. After a couple of days of experimentation and research it seems that neither Thunderbird or Apple Mail will retroactively download all images (or attachments).

The only way forward I can think of is to individually select each of the many thousands of emails to load the images, before then moving/importing to EF. I can’t imagine I’m the first, so any suggestion of this or another mail app that would accomplish this would be wonderful.

Thanks.

K

If you quit Mail and delete the IMAP cache folder for a mailbox, that should get Mail to redownload all the messages using your current settings. Then you would not have to select each message individually. The cache folders are stored inside a folder with your account name inside of the folder:

/Users/<username>/Library/Mail

or:

/Users/<username>/Library/Mail/V2

It might also work to tell Mail to move the messages to a local mailbox.

This shouldn’t be an issue for most people, since I believe with Mac OS X 10.9 and later Apple Mail always downloads the attachments.

Thanks. I can’t find the cache folder. But that could be new to V2, as perhaps it no longer requires one (?).

“/Users/<username>/Library/Mail/V2/user mailbox/INBOX.mbox/?”

Also, is there an equivalent for Thunderbird? I don’t see a cache folder in there either.

Thanks.

The cache folders are inside the folder called “IMAP-<your e-mail address>@<your mail server>”. Their names end in .mbox or .imapmbox.

I don’t know enough about how Thunderbird’s data store works to make a recommendation.

Oh, I see … everything inside “IMAP-<your e-mail address>@<your mail server>”. Did that. It worked.

I tried the same with Thunderbird, deleting the whole folder “mail.<yourdomainname>.com” and seemed to work there too.

Thanks.