C-Command Software Forum

Tags don't auto-refresh?

Hi,
New user here and couldn’t find anything in the manual or in the forum on this:

With a library open, I ran a Hazel rule to add tags to a file that needs to be OCR’d.
In Finder, the tags appear right away without refreshing. But in EF, they don’t appear unless I click on the file, and then they will appear. Is this normal behavior? I don’t see any type of Refresh command available from the menu bar. So will I have to click on each file to get it to update?

Also, if I delete the recently added tags, and then re-run the Hazel rule, the tags will not get added back again. I assume this is because it has already found a match as shown in the Rule Status window. By experimenting, I found that changing the rule name in Hazel will achieve the desired result. Is there any way to force a match “deletion?”

Thanks,
Jim

Yes. EagleFiler automatically syncs the tags when you open a library and every 2 hours thereafter. You can make it sync right away by clicking on a file or by holding down the Option key and choosing File ‣ Backup Metadata to sync the entire library.

This sounds like more of a Hazel question, unless you are seeing the same behavior when adding tags using Finder.

Thanks for your quick response!!! I guess it’s true what they say about your outstanding support :grinning:

  1. Thanks for the Backup MetaData info; wasn’t aware of that. Any chance of getting that on a toolbar icon, or at least, a key combination so it could be added as a last step to the Hazel rule?

  2. My mistake, that was a Hazel question and not EF. I was confused because re-running the Hazel rule executed normally and showed immediately in Finder, but not in EF since I hadn’t done the Backup MetaData trick.

Jim

Hazel could run an AppleScript that tells EagleFiler to back up the metadata:

tell application "EagleFiler"
    tell library document "YourLibraryName.eflibary"
        backup metadata
    end tell
end tell

Awesome! Thank you!!!