C-Command Software Forum

Train as Good and Train as Spam Keyboard Shortcuts not Working on Airmail 2

Hello -

I just installed the latest version of Airmail 2 with SpamSieve (2.9.23)
and I am having issues with the Train as Good and Train as Spam Keyboard shortcuts -
they are refusing to work for me - the drop down menu options work but not the shortcuts.
I have tried multiple times using different key combos in the system pref/keyboard with
no luck, any ideas?

Thanks - aosika

What shortcuts do you see in the Messages > Mark as Reminder menu?

Thanks Michael, so it appears you cannot override the shortcuts that Airmail has in place…if not thats fine, as long as they work.
Thanks for making a great product.

So it appears you cannot override the keyboard shortcuts set by Airmail, if not thats fine, its working for me now so that’s all that matters. Thanks for making a great product Michael.

Overriding them as described here is working on my Mac. If it’s not working for you, perhaps you could post some screenshots showing what you did and what the result (in the Airmail menu) was.

all good, working now - thanks again Michael

I have the same problem. Posting a screen shot wont help as there isnt a pop up declaring an error, just a tone (basso) and no action at all
The two training actions only work when doing a right click (control click) action. and I followd the directions to the letter in the PDF manual

The point of the screenshots is to see how you configured the keyboard shortcuts in System Preferences, whether they are shown in the menu in Airmail, and whether the corresponding menu commands are enabled.

here you go

Screen Shot 2016-03-30 at 13.11.01.png

and more

Screen Shot 2016-03-31 at 00.05.48.png

Screen Shot 2016-03-31 at 00.05.27.png

The issue seems to be that System Preferences says “Spam Sieve - Train as Bad” (as suggested in the manual) but that in the actual menu Airmail says “SpamSieve - Train as Spam”. The manual is correct for the Airmail 2.6.1, the current version in the Mac App Store. Which version of Airmail do you have? In any case, changing System Preferences to match what you see in the menu should fix the problem.

No it didnt help. No action except for Basso alert tone.

Screen Shot 2016-03-31 at 13.34.58.png

Screen Shot 2016-03-31 at 13.33.40.png

You have the same version of Airmail as me. I just realized that your second screenshot (with “SpamSieve - Train as Spam”) is from the contextual menu. The correct place to look for the keyboard shortcuts is in the Messages > Mark as Reminder menu. The menu titles there are the ones that need to match System Preferences.

You can enter this command in Terminal:

defaults read it.bloop.airmail2 NSUserKeyEquivalents

to see exactly what has been entered in System Preferences. On my Mac, it shows:

{
    "Spam Sieve - Train as Bad" = "@^s";
    "Spam Sieve - Train as Good" = "@^g";
}

aren’t your values reversed? you have train as bad with the good command and vice versa on good

anyway, here is my screen shot after the terminal command

Screen Shot 2016-03-31 at 15.23.48.png

I’m not holding my breath that we can fix this. I guess I’ll just have to use rightclick and select

Screen Shot 2016-03-31 at 15.28.57.png

Yes, it should be “s” for Bad and “g” for Good.

This looks good, although I guess it’s possible that the spacing or dash type is different. If you copy and paste your results we could do an exact comparison.

What does your Messages > Mark as Reminder menu look like? Are you running Airmail with the English localization?

Thanks for your help, but you can close this ticket.

Airmail is doing other stuff I can’t resolve so I’m switching back to Mail.app