C-Command Software Forum

Train as Good message disappearing!

I have just ‘Trained as Good’ a booking confirmation from EasyJet which went into spam… which then disappeared - it didn’t go back into my Inbox as it should.
Now when I request that EasyJet send me another confirmation, I see the email come into my InBox for a millisecond and then it goes again!! The email can not be found anywhere - not in Trash or anywhere else by doing a search.

I am using Apple Mail Imap on Lion.

Any thoughts gratefully received!

The messages are probably still there; Mail just lost track of them. First, I would suggest looking for the messages by searching for them with Spotlight (via the Spotlight menu, not in Mail) or Webmail (if your IMAP account supports that).

However, it sounds like the problem is due to Apple Mail’s database being damaged. To rebuild it you can quit Mail, then rename the file:

/Users/<username>/Library/Mail/V2/MailData/Envelope Index

to “Envelope Index Old”. When you re-launch Mail, it will build a new one. (Under Mac OS X 10.7 Lion, you’ll need to hold down the Option key when accessing the Finder’s Go menu in order to open the Library folder. Then open the Mail folder, then V2, then MailData to find the Envelope Index file.)

Thanks Michael. I have just searched in Spotlight, as well as on Apple’s MobileMe - and they’ve definitely gone. I’m wondering if it’s to do with where these particular emails come from… they are redirected from virgin.net to mobileme (IMAP), and perhaps the Train As Good doesn’t know where to put them back?? Just a guess.

Anyway, I searched other similar problems in the forum and as a result turned off the “Encoded HTML is spam” filter - which has solved the issue.

Thanks again.

It’s possible that “Train as Good” might not be able to figure out which account the messages are from. However, that wouldn’t cause the messages to totally disappear. It simply picks the most likely inbox that you have and asks Mail to move the messages there. Worst case scenario—unless Mail malfunctions—the messages go to the wrong inbox.

If you go to Mail’s Preferences window and look under Accounts, are there any accounts that are disabled? Sometimes Mail gets confused and the messages end up in the inbox of an account that’s disabled (and, thus, hidden). In that case, you could enable the account and look in its inbox.

Same Problem
I have been using SpamSieve for quite awhile with no problem but suddenly encountered this disappearing message thing yesterday. Noted it because an important message got sent to spam folder. I found it, trained SpamSieve that it was “good” at which pony it briefly appeared in my IN box, as expected, then disappeared again. Once it disappeared I could not find it again anyplace. Used Apple Mail’s Spotllght, searched trash folder and spam folder multiple times. Just to test it, I picked another spam message - a real spam message - and trained it as “good”. Same thing happened - briefly appeared in IN box then vanished without a trace.

I have tried the suggestions given - activated all disabled accounts and checked their IN boxes (nothing), checked SpamSieve filter options to see if I could turn off “Encoded HTML is Spam” filter (it was already turned off). Also tried rebuilding Library. Problem persists.

I am using Apple Mail App on Mavericks OS

Do you have more than one computer or device accessing this mail account? My guess is that the message was in the inbox, and then a filter/rule on the other computer moved or deleted the message. If the other computer is configured to use a Spam mailbox “On My Mac,” the message would no longer be on the first Mac, which would explain why your Spotlight search didn’t find it.

That was it

Yes, I figured it out yesterday. Discovered my email program and SpamSieve were running on a laptop that I thought I had shutdown. So, I was training it as good on my desktop, which put it back to the IN box on IMAP account and then SpamSieve on laptop was promptly snagging it and putting in spam folder on the laptop. Thus the disappearing message. Thanks for the feedback.