C-Command Software Forum

"Train as Good" not moving message

I’m using Spamsieve 2.8.6 with Mac OS X 10.7 and Mail Version 5.0. Initially, I was caught by the upgrade causing most of my mail to go to the Spam folder. I believe an email or warning of some type to all Mac OS X users would have been appropriate. I took me a few days before I realised this was happening.

Now that is corrected I seem to have another problem. That is “Train as Good” does not move the message from my SPAM folder to my INBOX. Any suggestions?

Lastly, I thought at one point that messages which were sent to a particular address would automatically result in Spamsieve treating subsequent received messages from the same address as good. I am definitely experiencing situations where that is not occurring. However, in browsing the preferences I do not seem to find a setting for that, so I am thinking I perhaps imagined this.

Any suggestions for either issue?

Indeed, this was posted on the blog and Twitter feed a week in advance and e-mailed to anyone who had opted into the SpamSieve mailing list.

What is the exact name of your spam mailbox? If it’s not “Spam” that may be the problem.

Do you mean messages sent from a particular address? SpamSieve will automatically whitelist these sender addresses if you have Auto-train with incoming mail and Train SpamSieve whitelist enabled. If you have those enabled but it doesn’t seem to be working, you should use the Open Log command to see whether SpamSieve thought those messages were spam; they may have been moved by some other rule instead.

I did not subscribe to any of these. I suspect I will subscribe to the mailing list. It certainly disrupted my email processing and I am puzzled by the failure mode. In my case I have some rules which run in front of the SPAMSIEVE rule so as to assure that certain messages are processed differently. Those gave me the false sense that things were working when in fact all email that should have been processed by SPAMSIEVE was not getting to my INBOX.

My SPAM folder is called “_SpamSieve”. It has always been called that for several years now and this is the first time I had a problem. That name is to assure it sorts to a particular location.

No, I mean messages sent to a particular address. The address is not in my address book. However, I have sent an email to that address. I thought such addresses somehow wound up being treated as if they were in my address book. I suspect I had a false assumption there.

I have looked at the log as well as my sent mailbox. I have confirmed that at 11:16 I sent a message to the address. At 13:41 when I received a message from that same address Spamsieve gave it a Predicted: SPAM (73) and then trained by adding to Spam Corpus.

Your further thoughts?

Does changing it to “Spam” help? Even if you don’t want to use that name, trying that would help narrow down where the problem is. Also, you can drag and drop mailboxes in Apple Mail to re-order them.

SpamSieve does not automatically whitelist “To” addresses, nor does it consider whether they’re in the address book. This would be counterproductive because most users’ addresses receive both spam and good messages.

However, you could certainly create a whitelist rule that matches “To (any address)” or “Any Recipient”.

I don’t understand—is the issue with messages that you’re sending to yourself? And no one else sends to that address?

I will play around with this later in the week. So I will go silent for a couple of days and report back.

As to your final question, I erroneously thought that my outbound messages to others, not to me, some how came into play. I understand they don’t. I was probably confusing with some other mail services scheme.

The main problem is that train to good stopped working after I upgraded to Lion and figured out I had to reinstall SpamSieve.

You should also check the log for “Trained: Good (Manual)” entries to see whether the training is occurring (as distinct from the message moving back to the inbox).

Yes, I’ve already confirmed in the log that the Manual train as good is logging a change to the corpus. So it is the physical move of the message which is the problem.

Hi Michael:

I finally got back to where I could try to track down the problem I was having with “Train as Good” not moving the message back to my inbox.

I noted in an earlier thread you suggested using the Mail Spamsieve - Change Settings command. That has fixed my problem.

I run Mail on different Macs when I travel. I recently changed my MobileMe settings to share Mail rules between machines. I think the problem was that I changed the Spamsieve rule on one machine which then changed a portion of the behaviour but I needed to use “Change Settings” to get the full behaviour.

Thanks