C-Command Software Forum

Train As Good stopped working after latest update

On Mac Catalina 10.15.7
I updated to the latest Spam Sieve recently (v. 2.9.42) and I’ve noticed that now when I select the occasional good email in my SpamSieve folder, that “Train As Good” no longer works. Nothing happens at all. The email stays in the Spam folder, so I have to manually drag it into my InBox. But I don’t believe it’s training it as Good as the next day, same vendor ended up in Spam again. Any ideas? Thanks. Apart from that, SpamSieve seems to be working fine.

Please try restarting your Mac and see if that fixes the problem. If not, please save a diagnostic report right after doing the training that didn’t work.

I restarted my Mac, and found one email (from Dropbox, in Yellow) in my SpamSieve folder.

Message > SpamSieve Train as Good did not work to move it.

Diagnostics report attached.

thanks,

Trish

Please check the Security & Privacy preferences and make sure that SpamSieve has Contacts access so that it can use the address book to help filter your messages. That may be why you are getting good messages in the spam mailbox.

Secondly, I think the reason that training did not move the message to your inbox is that you are using a custom mailbox name but did not tell SpamSieve that. So you should either rename your SpamSieve Incoming mailbox to Spam or use the Change Settings command to tell SpamSieve that you want to use that name for your spam mailbox.

Lastly, I recommend disabling or deleting your non-SpamSieve rules that move messages to the SpamSieve Incoming mailbox. These can mess up the training data and prevent you from accurately seeing what SpamSieve has done. One of these rules could also have been the reason the good message went to SpamSieve Incoming. If you really need such rules, move them above the SpamSieve rule and set them to use a different mailbox than SpamSieve.

Thank you. I add SpamSieve to Contacts.

I just went through Change Settings options and I think I found the culprit: For some reason, * When you use “Train as Good” on a message in the spam mailbox, should the message be moved back to the inbox?" was set to No. Not sure how that happened, as I don’t remember ever changing it!