C-Command Software Forum

Train as Spam always goes to On My Mac

Version 2.77 - OS X 10.6.2

Regardless of the setting I make in Messages > SpamSieve - Change Settings whenever I manually ‘Train as Spam’ the message goes into On My Mac > Spam rather than into My Account > Spam.

This appears to be a problem with the latest version of SpamSieve as I’m sure it was working previously.

Any ideas?

-darrell

I don’t think this is a problem with SpamSieve 2.7.7 because:

  1. I just tested it, and it worked.
  2. No one else has reported this problem.
  3. The relevant code hadn’t changed since September 2008.

Please make sure that “My Account” is at the top of the list in Mail’s preferences window and that the options in Change Settings are remembered between launches of SpamSieve and Mail.

Moving “My Account” to the top of the Accounts List appears to have fixed the problem.

The settings are now remembered between launches.

Thanks

-darrell

I’m have to report I’m having the same problem in Mail under Sno Leo 10.6-10.6.2

Please make sure that:

  1. The account appears first in the list in Mail’s preferences.
  2. The account has a top-level mailbox called Spam.
  3. Change Settings is set to not
    use a local spam mailbox and that this setting is remembered between launches of Mail and SpamSieve.