C-Command Software Forum

Train as Spam hotkey not working

This proably isn’t a SpamSieve issue, but its where I’m encountering it - I thought perhaps someone else has had the same issue.

So my command+controls+S hotkey does not function in SpamSieve. I went to Keyboard & Mouse in Prefs and created a new hotkey (both the same and a different set of keystrokes) and it simply won’t work within SpamSieve in either case.

teh Train as Good hotkey works fine as do all the other hotkeys in SS. Anyone seen this problem?

Do you have any utility software installed, e.g. QuicKeys, that might be intercepting that key combination?

I don’t. The only thing I can think of is the Microsoft Mouse software, but then that’s just storing hotkeys for trigger from the mouse.

One way to find the source of the problem would be to create a fresh OS X user account and gradually add your software until you find what’s interfering with that shortcut.

Or, there is a hidden preference for changing the SpamSieve shortcut. For example, you can open Terminal and enter a command like this:

defaults write com.c-command.SpamSieve AppleMailTrainSpamShortcut a

to change the shortcut to Command-Control-A. You can change “a” to any letter you like. You must restart Mail for the change to take effect.

Same here…

I feel dumb…as if there’s a simple setting i’m missing, but I also tried the terminal command above and used ‘s’ instead of ‘a’ at the end of the command and restarted mail. No juice. Any help.

Also, when I do tap Command-control-s the EDIT menu flashes, but no command on that menu shows the above key combo. wierd.

You didn’t say what “no juice” means: does it not show the new keyboard equivalent in the menu, or does it not work?

In any case, with Mac OS X 10.4 and later, you should use the Keyboard pane of System Preferences to change the keyboard shortcuts.

‘No Juice’ means it didn’t work. I’ve tried the keyboard system pref. and that doesn’t work either. I have no idea why it’s not working, obviously. When I press ctrl-cmd-s it wants to speak the text, but I have voiceover turned off. Who knows…certainly not me.

After using System Preferences and re-launching Mail, do you see the new keyboard shortcut in the Message menu in Mail? Could you send me your Mail preferences file?

/Users/<username>/Library/Preferences/com.apple.mail.plist

I did not receive the preferences file, so I’m assuming that tralfaz found the problem in System Preferences.