C-Command Software Forum

Train as Spam takes 2 attempts

OS 10.8.3, SS 2.9.7, Mail 6.3 (1503)
Whenever a piece of spam makes it through to my inbox, the first time I select it and “Train as Spam,” nothing happens. I need to select the menu item a second time in order for the spam to be moved to my Trash folder.
Also, When selecting “Train as Good,” though the email is no longer marked as spam, it no longer moves back to my inbox.

Have you changed anything in your Mail setup since these features were working properly?

Please check the folders:

/Users/<username>/Library/Mail/Bundles
/Library/Mail/Bundles

Are there any .mailbundle files there besides SpamSieve?

How long are you waiting after the first time? Does Mail’s Activity window (not the pane in the main window) show anything during this time?

Which mailbox is the message in when you train it as good?

It seems like its been at least 6 months, though I can’t be sure. Now that you mention it, it might’ve started up with the installation of Mail ActOn. (see next response).

Please check the folders:

/Users/<username>/Library/Mail/Bundles
/Library/Mail/Bundles

Are there any .mailbundle files there besides SpamSieve?

Yes, MailActOn.mailbundle. I’d forgotten that I was using this now, also. Conflict?

How long are you waiting after the first time? Does Mail’s Activity window (not the pane in the main window) show anything during this time?

When it is working properly, I usually see the “message” menu heading highlight immediately after choosing “Train as Spam.” When I don’t see this (after 2-3 seconds), I know it won’t do it at all. I can’t seem to recreate the problem at the moment, but don’t recall anything showing up (at least not long enough to register) there. I’ll keep an eye out next time.

Which mailbox is the message in when you train it as good?

The “Spam” folder.

Thanks for your prompt response!

I’m not aware of any conflicts with MailActOn, but does the problem go away if you temporarily uninstall MailActOn and restart Mail?

What if you choose the command from the menu yourself instead of using the keyboard shortcut?

If you choose Change Settings, is it set to move messages when you “Train as Good”?

Sorry it’s taken me so long to respond. I’ve had what seemed to be a intermittent return of the behavior, but just today, I think I’ve figured out where my mistake was.
Normally I view my individual inboxes in Mail. SpamSieve behaves normally in this situation. Occasionally, however, I find myself inadvertantly viewing my incoming mail in the “Received Today” Smart Mailbox. Obviously, any attempts to train emails as Spam would not appear to be successful, as the mail would remain that smart mailbox.
Thanks for your attention!