C-Command Software Forum

Trouble Installing on Catalina (10.15.5)

I was using SpamSieve just fine for many months on Catalina, then today I rebooted after an OS update & SpamSieve had been disabled by the OS. I tried re-installing from the DMG of SpamSieve-2.9.39 from the website, but when I drag the application into the Applications folder, I get the following:

“SpamSieve” cannot be opened because the developer cannot be verified.

The first few times I tried this, it complained that the application is “damaged” so I re-downloaded it a couple of times.

I fixed this by going into the System Preferences > Security & Privacy > General tab & clicking on “Open Anyway” next to the message about Spam Sieve not being from an identified developer.

I’m posting this, just in case others run into the same thing (or if for some reason the app really should be signed & I have a bad copy).

Are you referring to the Apple Mail plug-in?

The app really is signed and notarized, and the ticket is stapled so that macOS should be able to verify it without a network connection. It seems unlikely that you would have a bad copy if the .dmg file successfully mounted. Perhaps this is a temporary macOS issue and that restarting your Mac would help.

Note that your Mac does need a network connection in order to verify the notarization of the Apple Mail plug-in on Catalina.

I think so, Apple Mail plug-in is what I’ve been using. But I got this message when downloading the application and dragging it to the Applications folder

For what it’s worth:

$ md5 SpamSieve-2.9.39.dmg
MD5 (SpamSieve-2.9.39.dmg) = 8c46c1e0c01254f7b4d1180ad01622e1

if you want to see whether your copy was correct.

Looks correct, thanks!

-Jess