C-Command Software Forum

troubleshooting a speed issue


I have had some speed issues with EagleFiler lately that I can’t seem to track down.

I get a spinning rainbow wheel for 1-2 seconds before basically every UI interaction. I noticed it while using the capture key, but it happens in the main app too. Clicking to open a menu, selecting a record in the record list, clicking on the title field to rename it - every mouse interaction takes a second or two before registering.

Now, I have rearranged my libraries during the spring so I don’t know whether I caused something to mess up. I have some folders cloud synced using the provider Tresorit, one library has ≈8K records and the other ≈1K so they’re not huge. Mostly files like markdown files and pdf’s.

This is what I’ve tried:

  • Turned off cloud sync
    I thought the syncing would trip EF up, but the problem remains without it.
  • Rebuild the libraries
    I thought there was a problem with the index after I had rearranged so many files, so I rebuilt both of the libraries. No luck.
  • Turn off other applications
    While yes, my computer is coming of age and does not have a lot of RAM, I haven’t seen a difference in speed when many or very few apps are open

This is a fairly recent thing. EF have worked perfectly for me for many years.

I’m on a MacBook Air with MacOS 10.12.6 and EagleFiler 1.8.3

Please see this page for how you can record some sample reports that show what is happening during the beachball.

Thanks for sending the sample reports. The interesting parts to me are:

1700 -[NSTextInputContext invalidateCharacterCoordinates]  (in AppKit) + 45  [0x7fffa9b18698]
  1700 +[NSTextInputContext currentInputContext_withFirstResponderSync:]  (in AppKit) + 362  [0x7fffa9b15ec2]
    1700 -[NSTextInputContext activate]  (in AppKit) + 284  [0x7fffa928488d]
      1700 MyActivateTSMDocument  (in HIToolbox) + 1910  [0x7fffaabbdee8]
        1700 utOpenActivateAllSelectedIMInDoc  (in HIToolbox) + 187  [0x7fffaabc5384]
          1700 CFArrayApplyFunction  (in CoreFoundation) + 68  [0x7fffab60be34]
            1700 utOpenActivateAllSelectedIMInDocIterator  (in HIToolbox) + 21  [0x7fffaad90334]
              1700 utOpenActivateSelectedInputMethodInDoc  (in HIToolbox) + 369  [0x7fffaad904ca]
                1700 ActivateInputMethodInstance  (in HIToolbox) + 100  [0x7fffaad9bb3c]
                  1700 IMKInputSessionActivate  (in HIToolbox) + 36  [0x7fffaad9c7ab]
                    1700 -[IMKInputSession activate]  (in HIToolbox) + 441  [0x7fffaade7b7a]
                      1700 -[IMKClient(IMKClientConnection_XPC) remoteXPCProxyForSession:fromCaller:]  (in HIToolbox) + 1648  [0x7fffaade1648]
                        1700 -[IMKClient _startServer_AllowingSandboxExtension:]  (in HIToolbox) + 1599  [0x7fffaadda41c]
                          1700 -[IMKClient _launch:fromBundle:throughPort:usingSBExtension:]  (in HIToolbox) + 708  [0x7fffaadd984b]
                            1700 CFMessagePortSendRequest  (in CoreFoundation) + 965  [0x7fffab6ab3d5]
                              1700 CFRunLoopRunSpecific  (in CoreFoundation) + 420  [0x7fffab649114]
                                1699 __CFRunLoopRun  (in CoreFoundation) + 1361  [0x7fffab6498c1]
                                + 1699 __CFRunLoopServiceMachPort  (in CoreFoundation) + 212  [0x7fffab64a434]
                                +   1699 mach_msg  (in libsystem_kernel.dylib) + 55  [0x7fffc0ef4797]


861 DeactivateInputMethodInstance  (in HIToolbox) + 100  [0x7fffaad9bba9]
  861 IMKInputSessionDeactivate  (in HIToolbox) + 36  [0x7fffaad9c7db]
    861 -[IMKInputSession deactivate]  (in HIToolbox) + 730  [0x7fffaadea1bd]
      861 -[IMKClient(IMKClientConnection_XPC) remoteXPCProxyForSession:fromCaller:]  (in HIToolbox) + 1648  [0x7fffaade1648]
        861 -[IMKClient _startServer_AllowingSandboxExtension:]  (in HIToolbox) + 1599  [0x7fffaadda41c]
          861 -[IMKClient _launch:fromBundle:throughPort:usingSBExtension:]  (in HIToolbox) + 708  [0x7fffaadd984b]
            861 CFMessagePortSendRequest  (in CoreFoundation) + 965  [0x7fffab6ab3d5]
              861 CFRunLoopRunSpecific  (in CoreFoundation) + 420  [0x7fffab649114]
                860 __CFRunLoopRun  (in CoreFoundation) + 1361  [0x7fffab6498c1]
                ! 860 __CFRunLoopServiceMachPort  (in CoreFoundation) + 212  [0x7fffab64a434]
                !   860 mach_msg  (in libsystem_kernel.dylib) + 55  [0x7fffc0ef4797]

These seem to indicate that macOS is stuck waiting on some other process that related to input. I don’t know what’s causing this, though. Do you have any extra software installed that’s related to text input? Since the delay doesn’t seem to be EagleFiler’s code, this is probably something that would need to be addressed on your Mac. It may help to do a safe boot or to update to macOS 10.13.