C-Command Software Forum

Unable to delete SpamSieve on my Mac

No success here either. Tried all the Apple suggestions too!

Those commands were not a suggested solution. They were to try to figure out what the problem is. Please try entering this command:

ls -leaR@ ~/.Trash

and tell me what it shows.

This article suggests that you may be able to Control-click on the folder in the trash and choose Delete Immediately from the contextual menu.

It may also help to start up your Mac in safe mode and then try emptying the trash. You can keep holding down the Shift key after the login window to prevent other apps from launching.

I also see that @JBP’s folders have the com.apple.macl extended attribute, which can be troublesome to delete. It may help to temporarily disable System Integrity Protection and then try emptying the trash.

Tried the Safe Mode option and Delete Immediately several times already.

Thanks for the screenshot from Terminal. However, that doesn’t seem to match the Finder screenshot that you sent before. Does the Trash window now show a junk folder when you open it instead of the SpamSieve.mailbundle folder that was shown before? The MacOS that was “in use” before doesn’t seem to be there.

There doesn’t appear to be any permissions.

Sorry I tried changing the names of the files.
This is what it shows now:

Trying to delete again…

If you enter this Terminal command:

lsof | grep .Trash

it may show which process is using the files in the trash.

CleanMyMac?

The screenshot seems to show that the SpamSieve files in the trash are not actually in use. CleanMyMac is just using the trash folder itself. It’s possible that:

sudo lsof | grep .Trash

would show a privileged process that’s keeping the file open, or perhaps the error that Finder is giving you is incorrect.

The sudo lsof | grep .Trash command returns nothing in my case

Did you try the other ideas here?

I ran the csrutil disable command from the recovery mode this morning and was able to clear out the trash. Thank you so much!

1 Like

Great!

@Johnny I think the error message is in error because that still isn’t showing any trashed SpamSieve files in use. I suggest that you try temporarily disable System Integrity Protection and then try emptying the trash.

Thanks Michael… it worked!! It’s been driving me nutty. Sadly the Terminal scares me a bit but I managed to do it.

Thanks again for all your help.
John

1 Like