C-Command Software Forum

Unable to delete SpamSieve on my Mac

Have been using it for years with no problems. Yesterday I had to do a reinstall of my complete system. For some reason the extension wouldn’t load onto Apple Mail.

Got into a real mess following instructions so decided to delete SpamSieve and reload from backup. When I try to delete I get ‘The operation can’t be completed because the item “MacOS” is in use.’

Anyone any ideas?

If a file is in use, you can restart your Mac and try again. However, I’ve never seen deleting the SpamSieve app to help with a Mail plug-in problem.

Due to macOS’s protected folders, plug-in loading problems are usually not fixed by reinstalling and restoring from backup. In fact, that can create problems where there are none because of the way macOS’s migration/restore works. So I generally recommend manually removing the old plug-in and then installing it again. If you need further assistance, please send in a diagnostic report.

I have this sitting in my Trash and unable to delete.

Screenshot 2020-11-16 at 14.57.41

If it’s in the trash, it’s not affecting Mail or macOS, so deleting it won’t change anything (except save a little disk space). You should be able to empty the trash after restarting the Mac.

But it won’t delete after restarting. I’ve tried a couple of times. I get these 3 windows coming up on restart.

SpamSieve shows the Welcome window and help if you have not trained it with at least one good message and one spam message. Did you follow the instructions to do an initial training? It’s expected that it would start out empty again if you deleted everything as described in your original post.

I don’t know why Finder would report the file in use after restarting—and MacOS is not even a file, it’s a folder. You could try entering this command in Terminal:

sudo rm -rf ~/.Trash/SpamSieve.mailbundle

to delete it.

It says ‘not permitted’

You say it’s a folder but inside is a file called SpamSieve

What do these commands show:

ls -lea ~/.Trash/SpamSieve.mailbundle
ls -lea ~/.Trash/SpamSieve.mailbundle/MacOS

?

Operation not permitted.

It may help to give the Terminal app Full Disk Access in System Preferences ‣ Security & Privacy.

I have been following this thread since I am having a similar problem deleting some folder with files in the trash. They are:


I have, after a couple of tries successfully re-installed SpamSieve and it is working but having tried all of the methods you suggested, I am unable to get these files to empty from the trash. Can you figure this out?

What happens when you try the Terminal commands that I suggest above?

I get this:
~ % ls -lea ~/.Trash/SpamSieve.mailbundle

ls: /Users/jburtpittman/.Trash/SpamSieve.mailbundle: No such file or directory

Please try:

ls -leaR ~/.Trash/

This is what I get.
Terminal Results.pdf (16.8 KB)

If looks like you have an ACL permissions override set on your trash that prevents files from being deleted. It doesn’t seem to be specific to the SpamSieve files. You should be able to remove the ACL using this Terminal command:

sudo chmod -RN ~/.Trash

Didn’t work. Anything else I put in the Trash empties fine. Next try.pdf (14.5 KB)

This is the desktop message I get when I try to empty the Trash.

How about:

ls -leaR@ ~/.Trash

?

Terminal Results.pdf (18.4 KB)