C-Command Software Forum

Using 2 Macs at once, new install has changed the behavior from the past

I’ll try to make this short. I’ve used SS on multiple Macs for years. I have one Mac running 24/7 (Mac A) with SS on it, and another Mac (Mac B) I use just during the day for work, it also has SS installed on it.

Now, normally, I train both Macs randomly, whichever one I’m working on. It’s been fine. If SS flags mail as Spam on A, it goes into A’s Spam folder. The beauty is that I could click the Spam folder on EITHER Mac A or B, and see all the same spam for BOTH machines! I’m not using any Drone setup, or anything, two independent SpamSieve installs both working on the same IMAP email boxes.

I loved it, as I could be at Mac B, and see spam mail in there, from either machine, and manually fix the occasional good email, training it as Good. If I manually emptied this Spam box by selecting all and deleting, it would delete all the mail on BOTH Macs A and B.

My problem is this…I had to reinstall the macOS Mojave on Mac B, and did my normal SpamSieve install just as I’ve always done. I have the local Spam folder setup, all the same as usual.

But after a few minutes, I no longer have the Spam mails going into the Spam mailbox. Mac A is fine, it has spam in the Spam folder just as usual. I just can’t see it anymore in Mac B like I used to. I see the red notification circle on the Mail app in the dock, for a split second, then it goes away, and no mail is in the Spam box.

Both Macs have the same osX Mojave. Up until 2 days ago when I reinstalled Mac B, everything was fine. I can’t imagine what is different?

I tried this:

  1. Did a complete Uninstall on Mac B, and did a fresh install.
  2. Turned off on both Macs, the “Auto Train with incoming mail”

I’m at a loss?

I need the ability to see and manually train the Spam coming in from both on either machine, just like I’ve always had.

HELP!

This should work fine, but you need to adjust the Apple Mail rule and training settings (on both Macs) to tell it that you’re Using a Spam Mailbox on the Server.

I wonder why I’ve never had to do that until now? I’ve always, for years, used your basic Apple Mail instructions, which is Spam folder on Local Mac, yet I could see spam in there from both computers at the same time.

That’s what I can’t figure out, why now is it different?

I tried to make a new Spam folder using one of my 3 emails that are on my IMAP server, and it doesn’t show up in the sidebar of Mac Mail, so I can’t really see it. Bummed.

It’s not possible for local mailboxes to sync, so you must have been using a server mailbox before.

It’s possible that you have the Mailbox Behaviors preferences in Mail set to show a mailbox named Spam as the special Junk mailbox. So you could either change that preference or create a shared mailbox using a different name, such as SpamSieve.

The plot thickens. I quit the Mail app on the 24/7 Mac A. So only Mac B is working.

Some mail came in to my inbox that was spam. I did the “train as Spam” thing, and it disappeared, but never showed up anywhere at all. The local Spam mailbox remains empty.

So it’s not apparently an issue with both Macs communicating, but just my one daily Mac. Where on earth did it go? The rule says to send spam to Spam on my local Mac just like your instructions. It’s the only Rule I have. Everything is else is default.

The weird thing is, it did work fine for a few minutes, then all of a sudden quit behaving normally. Both times, initial install, and after a complete reinstall of SS. I would think it would be all or none, not for an hour, then change.

here are 2 screen caps to look at.

The rule is for incoming messages. When you manually train a message as spam, it goes to the location specified in Change Settings.

It is normal that Mailbox Behaviors does not let you select an arbitrary On My Mac mailbox to be the special Junk mailbox.

I also see that you have mailboxes inside your IMAP inbox, which could indicate that your IMAP Path Prefix is not properly set to “INBOX”.

I noticed all those inboxes, I don’t have them for the other emails, just this one. WHy on earth do I have so many I wonder…

You mention “your IMAP Path Prefix is not properly set to INBOX”, what does that mean? I’m not sure?

I have it set to send Train as Spam to this Spam box, but nothing shows up there. It does just fine on the other Mac with identical settings.

You can fix it in the Advanced IMAP Settings in Mail’s Accounts preferences.

Please check Change Settings for whether you have it set to use a local or server mailbox.

None of my Advanced IMAP settings have anything in them, they are blank for all accounts and macs.

I guess I don’t know enough about all this behind the scenes stuff to make any progress. It’s been fine with default installs for at least 5 years no matter which macs I use, I have a laptop setup the same way.

Why this one Mac won’t “stick” I guess I’ll never know. I give up. Thanks for your efforts anyway.

Then I recommend that you check the mailboxes inside the inbox for the graphikjam account and see if any of them have any messages in them. If the mailboxes are empty, you could delete them.

As I said, it’s not possible that it worked the way you described using a default install.

In any case, the first step to getting it to work the way you want is to create a new mailbox (I recommend calling it SpamSieve so it doesn’t get confused with other Spam mailboxes) in one of your IMAP accounts. Then make sure that you can see this same mailbox on all your Macs. This is just basic Mail stuff that has nothing to do with SpamSieve or settings. Mail should always show the same mailboxes on each Mac.

I swear I’ve always used the default install instructions on 3 macs at a time, and it always sync’d up. Maybe I just got lucky!

Once I make the mailbox in one of my IMAP accounts, I’m guessing I then change the Rule I have to send spam to this new mailbox, instead of the default local Spam box, right?

I tried to make a new mailbox, called SpamSieve in just one of the IMAP accounts. I don’t see it anywhere, and when I go to the Rule, it doesn’t show up as an option for where to send all the spam…so that was a bust.

Right.

How about if you go to iCloud.com in your browser and make it there?