Using SpamSieve with a patched legacy OS

I am currently running SpamSieve on my mid-2012 MacBook Pro with MacOS Mojave, and it works extremely well to identify and isolate spam email. I am now considering using OpenCore Legacy Patcher to patch my unsupported Mojave OS up to Ventura (Sonoma still seems to be a work in progress). Are you aware of any issues associated with running SpamSieve on a patched legacy OS?

I have not heard either way about using SpamSieve with OpenCore Legacy Patcher. My guess is that if you can get macOS to work then SpamSieve would, too.

Thank you!