C-Command Software Forum

Using "Train as Spam" does not move messages to Spam folder

I’ve been usig SpamSieve for months (with the latest version of Apple’s Mail), and when it doesn’t catch a spam message and places it in my Inbox, then I just highlight the message and choose “Train as Spam”, which causes it to be automatically moved to my Spam folder (where all junk mail goes).

BUt a couple of days ago, this process stopped working. When I see a spam message that’s gotten into my Inbox, I try to “Train as Spam” it, but instead of moving the email to my Spam folder, it simply gives the email a grey color, and leaves it in my Inbox.

Any idea why, and how to fix?

Thanks!

P.S. You can see a screen shot here. Note all the spam messages in grey. Normally, they move to the Spam folder, but have stopped doing that.

http://www.k2films.com/SpamSieve.jpg

You didn’t say which version of OS X you have, so I will assume you have Tiger. Please select a spam message in Mail. Then open the attached file in Script Editor and click the Run button. Does it move the message to the Spam folder? Does it report an error? This may give us some information about where the problem is.

Hi Michael -

I’ve recently run into the same problem above.

I’m running an Intel Mac 10.4.10.

I’ve downloaded the Script above and when I selected a message and run the script, I get a “NSInternalScriptError”.

Any thoughts?

SpamSieve is still clocking spam and moving it there but for the ones it misses, and where I select Train as Spam, it still sits in my inbox.

Thanks.

Meaning that it turns gray but doesn’t move to the Spam mailbox?

Is there an error number reported? Which line is the script at when the error is reported?

What happens if you use “Train as Spam” (the new script) on a message that’s in the Spam mailbox? Does it still report an internal error?

Hi Michael -

  1. It doesn’t turn gray, sorry. It just stays put.

  2. I just tried it again and it now moves an email to the Spam folder. However, Train As Spam won’t. That’s odd.

  3. However, now it gives me the same error as above (no error number and no line indication) if I do Train as Spam in the Spam mailbox.

Thanks.

Yeah. Were you using it on a different message or something?

When you run it in Script Editor and it reports an error, it won’t tell you a line number, but it should select the problematic part of the script.

Hi Michael -

Sorry for the late reply – I was out of town for my wedding.

To answer your questions:

  1. I believe so.

  2. Here’s the bit:

			if not my isInSpamMailbox(m) then
				copy m to end of messagesToMove
			end if
		end try
	end repeat
	try
		my moveToSpamFolder(messagesToMove)

Didn’t it select one particular line?

Unfortunately, it didn’t.

In the results log, I get “{button returned:“OK”}”.

I’ve tried re-installing SS and also re-installing the plug-in and re-doing the rules and all but to no avail.

It still catches Spam wonderfully but for the ones it doesn’t, the Train doesn’t work, which bewilders me why all of a sudden it doesn’t.

Would it possibly have to do with a conflict elsewhere? The only thing I can think of that’s been tweaked system wise is the install of Adobe CS3 and I used the Adobe clean up prog to clean up any stray files from the beta.

OK, please try running this script in Script Editor.

Interesting - I just upgraded to 2.6.3 and now everything works again.

Was there a fix of some kind in that?

Thanks.

That’s odd, because there wasn’t. I’m glad it’s working for you now, though. :slight_smile:

So am I!

I’m going to guess some kinda system setting was borked or there was a ghost in the machine.

Thanks again for the help Michael.

I am having the same problem - ‘train as spam’ will highlight the message in grey, but does not move to the spam folder.

I am using 10.4.10, and the folders Im viewing are smart folders (e.g., one is for today received, personal email - filtering out work email).

Ran the last script posted in this thread:

Mail got an error: NSInternalScriptError
and it stopped on the move messagesToMove to mbox line.

shelley

Just to be clear, moving the messages to the Spam mailbox will not affect whether they appear in a smart mailbox unless the smart mailbox’s criteria specifically exclude messages in the Spam mailbox.

Is it possible that some of the messages you’re trying to move are already in the Spam mailbox?

What do you see in the Result tab when running this script?

Same problem here, too!
Dear Michael,

I’m having the same problem here, too. I’m running SpamSieve on two computers, one MacPro and one iMac, both with Entourage, and both connected to an Exchange account.

On the iMac it works like a charm, on the MacPro it doesn’t move the mails to the Junk folder. I just re-installed everything there, but still the same story.

From what I understand, there’s still not solution … but I’d be happy to hear from you, once there is one.

If by “same problem” you mean “Using ‘Train as Spam’ does not move messages to Spam folder,” that is the expected behavior for Exchange accounts, due to a limitation of Entourage.

Oh, really? Well then …
But why does it move my Spam messages on the iMac, which is also on the Exchange-account?

I don’t know. Maybe there are situations where it works with Exchange accounts, but I’m not aware of any. Are you sure the messages in question were not stored in local folders on the iMac?

Oh, that could be, I’d have to look. But in any case, they are being moved out of my inbox, instead of just getting coloured as on the Mac Pro.