C-Command Software Forum

Volume is "out of space"

Hi There,

I am using the dropdmg command line tool to build my product’s dmg file for shipping. Lately it has been giving me an occasional problem where it asks for an admin password and it will usually fail in these cases. Before I could restart the app and it seemed to work fine. However, today I cannot get it to work at all. I’ve got a Configuration defined in the prefs, that I have exported as well to put into my project hierarchy. If I run it from the command line in the build phase of my project it asks for a password then fails with the following message:

Error You can’t save the file “.DropDMGBackground” because the volume “Tealeaves” is out of space.
Remove some files from the volume, and then try again.

So I tried dropping the same folder onto DropDMG to see what it does. I get the same issue (using the configuration from the prefs rather than my exported one, which should only be different by the background image).

The original folder has a single item in it (my complete installer) that is about 18MB. That folder is called “Tealeaves” and the single item is “Open to Install Tealeaves.app”. What I found is that in either case the dmg that is created (remains open but doesn’t save) has the single item “Open to Install Tealeaves.app”, but has also copied an additional copy of that same file inside of the first, so the total size is 36 MB.

So two things:

  1. Is there a limit to the size of the file that can be created? I can see where I can adjust this.

  2. Why is it copying a second version of the file inside of the first one?

BTW, I did check the original folder after running both ways and it did not have the double file. Also, I tried build a dmg (using the same configuration) with another folder and it worked fine!

I hope you can help me, since this is hindering my ability to ship! o_0

Just to offset my hysteria, I just want to say that this tool is awesome and has made my delivery process great :wink:

Thanks,
Scott

If you don’t want to deal with it asking for the admin password, please see the Always run with root access option.

No. DropDMG automatically chooses a size based on the size of the items that you ask it to put on the disk image. It sounds like the size is OK and the real problem is #2.

I’m not sure. Please contact me via e-mail and include some screenshots showing your source folder and the destination image with the “double file” so that I can see what’s happening here. Also, please include all the information requested here so that I can help you ASAP.

It looks like the problem was due to the permissions of the source folder. When Scott rebuilt a clean copy of his app, he was able to create the disk image.