Was working and now it’s not

Was working flawlessly but now for a reason unknown to me no spam in my university inbox is being caught, but all the GMail spam is being caught. I haven’t tinkered with any settings in Apple Mail or SS.

Looking at the log SS is predicting these emails as spam but they are remaining in the inbox as unread.

If I manually train an inbox spam it does correctly go into the junk folder.

MacBook Pro, OS 14.4.1, SS 3.0.4b2

What should I send you to investigate? I can see the log-how can I save it to send it?

Please see the Why are messages marked as spam in Apple Mail but not moved? section of the manual.

Michael, thanks for the reply. Regarding your direction to the 7.13.8 manual section :

I don’t think it applies-the messages are identified as spam (90-99) in the log but are not colored in the inbox.


  1. The Junk folder is correctly named Junk. Manually tagging the emails as spam marks them and moves them to the junk folder.
      1. Do not apply bec I’m not using the plugin
  2. Rebuilding the Mail database did not fix the issue.

Hmm, that is strange because if they are shown as spam in the log they should be colored in Mail, unless you turned the coloring off. And the automatic filtering and the manual training move the messages to Junk in exactly the same way, so if one works I would expect the other to as well.

If you select a message in the inbox that didn’t move (but is shown as Predicted: Spam in the log), what happens if you choose Filter Messages from the SpamSieve menu bar icon? Does the message move? Does it make a new Predicted: Spam entry in the log? Does the log entry have an arrow next to it?


It is strange. Color was not turned off in Settings>Advanced. If I train one of the uncaught spam messages in my inbox it goes right into Junk with color.

I think I may have confused the matter by saying the messages showed up marked as spam in the log, but the reason was certainly because I had previously marked them as spam before checking the log. Dumb on my part.

Here’s the sequel. SS seems to be working normally now. The only change I made was to turn on the green flagging of scanned good messages in Settings to see if SS was seeing those spam messages.

I was going to try the rescan command but I couldnt remember where it was or find it bec I had the menu bar option turned off. Why doesn’t that order also appear in the task bar? It ought to IMO. If this bug reappears I’ll rescan and let you know.



That’s good to hear but doesn’t really tell us what the fix was. The green flag setting doesn’t change how filtering works; it just helps you see which messages are waiting to be filtered. Spam messages, which is where the problem was, would never get green flags, anyway…

The Filter Messages command appears in both the SpamSieve menu bar icon and in the Dock menu:

Thank you again.

Does this make sense: Though Mail is running on a sleeping computer and emails should be processed by SS, the emails I see on my iPhone show spams in the inbox. But when I go to the computer and bring Mail onto the screen, they then disappear.

Sorry about the confusion about rescanning the inbox. I was looking for a command “Scan” but now I see the Filter command.

Yes, Apple Mail’s ability to filter messages during sleep is limited.