C-Command Software Forum

Web archive is always imported from Safari, despite format chosen in Preferences

I have selected Rich Text With Images in EF’s Preferences dialog as the Web Page Format. In Safari, I select the portion of a webpage, right-click, choose Services, then either of “EagleFiler: Import With Options” or “EagleFiler: Import”. After a moment (and after completing the dialog if “With Options” was chosen), a web archive file appears in EagleFiler.

I tried to import as Bookmark, HTML, Plain Text, Rich Text With Images, and PDF, and still get a web archive.

I tested using two different libraries and get a web archive in both, despite that Preferences is not set to import as web archive.

I have checked that this is not just a glitch in what is displayed in the Records list by selecting one of the imports and checking in the Inspect dialog; it shows Web Archive.

I have made sure that EF is enabled in System Preferences-Security & Privacy-Accessibility and -Automation.

This behavior persists after quitting EF and running it again, and after a reboot.

Not sure what to do. Thanks for any advice.

iMac 18,3, 24gb memory (plenty free)
Mojave 10.14.1
Safari 12.0.1 (14606.2.104.1.1)
EagleFiler 1.8.10

The Web page format applies when you import an entire Web page. If you’re importing just the selected text using the service, EagleFiler uses the Web archive format by default. You can change the ImportTextAsWebArchive setting in the esoteric preferences if you prefer RTFD.

Thanks very much. I had conflated capturing a selection and an entire webpage. Problem solved. Sorry for the trouble.