C-Command Software Forum

Weird Behavior with El Capitan

I have two issues and not sure if Mail problem or SpamSeive or both.

  1. It seems that Mail will bog down and fail to retrieve new mail perhaps most notably after a sleep/wake cycle or after several hours. Sometimes restarting the machine is needed to get things cleared up.

  2. The drone moves junk mail to my server junk folder, but satellite machines are marking the mail as junk mail and leaving it in the inbox, perhaps as a ghost mail. Sometimes the mail will move on its own in a bit, sometimes I have to exit Mail and restart it for the marked mail to clear.

I thought these issues my be related to my 2008 Mac Pro being a little tired after these upgrades, but these same problems exist on a new iMac which is now the drone machine and of course on a fresh install of El Capitan.

I have tried some if the uncheck/recheck workarounds that I’ve seen in my research of any Mail issues with El Capitan. My Apple junk mail filtering is turned off in Mail, although the satellite machines appear to mark the mail as junk in “Apple style”, not SpamSeive coloring.

I also have SpamSeive set to not close with mail.

Any thoughts welcomed.

I have seen this, too, with El Capitan, even with SpamSieve uninstalled. The best workaround I’ve found is to go into Mail’s Accounts preferences and disable and then enable the “stuck” account.

I’m not sure what you mean by “ghost.” Are you saying that the messages are in two mailboxes at once? Are you able to log into Webmail to see whether the messages are actually moved to the Spam mailbox on the server? If so, then the problem is likely on the non-drone Macs.

It is possible that the junk flag (which SpamSieve sets when it thinks a message is spam) is syncing from the drone to the other Macs, so I wouldn’t worry about that.

What I mean by “ghost” is that the mail has actually been moved to the server Spam folder and is no longer in the Inbox, yet the non-drone Macs still show them in the box, even after new mail has been fetched. However, closing and restarting mail on the non-drones will stop them from showing in the inbox. It seems that the non-drones do not synchronize the status of old mail.

That sounds like a Mail or server issue. Or perhaps the messages are deleted but not expunged, and you have Mail set (in the View menu) to Show Deleted Messages.

didn’t even know about Show Deleted Messages. It is grayed out in the off setting so I don’t think that is the issue, but good to know. I agree that it is a mail issue. They already had some Mail bug fixes related to this in the first update. Hopefully, more to come. How frustrating. No more updating to a new operating system for 3+ months for me!

So, this problem continues and I have looked at the log in Console for mail and see the following log. It appears that SpamSeive ran all night just fine and then this note with a couple of SpamSeive entries about 20 minutes apart after that. Then nothing. It seems that in the morning I see “Checking for Mail” in Apple mail and the process is stuck.

I actually un-installed and re-installed SpamSeive yesterday and it did nothing for the problem. I’ve deleted and re-installed each mail account and it didn’t help. I have disabled the only bundle I run other than SpamSeive which is Act-On and that doesn’t help.

Is this possibly a server issue? I use Westhost and Apple Mail has had its issues with them. For one thing, I have to disable “Automatically detect and maintain Account settings” in Apple Mail or their server with identify my IP as a SPAM attack attempt and lock it up.

Very frustrating. Here’s the log message:

11/24/15 5:59:52.052 AM Mail[1993]: Failed to open emlx and partial.emlx files (/Users/kemper/Library/Mail/V3/EC7BD6D2-24CD-41EB-BC7B-1DD9882C0B69/INBOX.mbox/F8C6C38F-85CA-4149-83BB-D7C6059473A4/Data/4/1/1/Messages/114813.partial.emlx)

What were the SpamSieve log entries?

Sorry to say, but it sounds like a Mail issue to me.

I don’t think this is necessarily related to the problem you are having. I think it just indicates a minor error with Mail’s message cache.