C-Command Software Forum

Why do I need to "Apply Inbox Rules" every morning?

I recently noticed something that seems to be new to me: when I start Apple Mail in the morning, I see messages in my inbox that are obviously spam. They are not coloured as spam. If I then run “Apply Inbox Rules”, these messages are moved to the spam folders used by SpamSieve, as they should be.

Is there a reason for what seems to be a change in behaviour? I haven’t noticed this problem during the rest of the day, only at morning startup.

I have not recently changed anything important on my Mac other than applying the usual system and application updates (using Mojave 10.14.6 and Apple Mail 12.4). Also, I recently removed old unused stuff from SpamSieve’s whitelist. Oh, and I’m using MailTags (latest version), but have been doing so for years.

Ellen

That’s not normal. Are the messages arriving already marked as read? Even though they aren’t colored as spam, have you checked SpamSieve’s log (before applying the rules) to see whether those messages are mentioned?

About how long does it take Mail to launch in the morning? Does it help if you launch SpamSieve first?

Here’s the result of my tests two days in a row when turning on the Mac in the morning:

Day 1

  • Mail is in Startup Items and launches, very slowly, as usual (about a minute or more).
  • SpamSieve launches.
  • One obvious spam is in the Inbox, not read, not colored.
  • SpamSieve log: just the first two lines:
    Launched: 2.9.39 (2939100) on macOS 10.14.6
    Date: 2020-08-11 07:54:07 +0200 (GMT+2)
  • Apply Inbox Rules activated.
  • The obvious spam is sent to the Spam folder.
  • It appears as “Predicted” in the log.

Day 2

  • SpamSieve is in Startup Items, but not Mail.
  • Manual launch of Mail which launches faster than when it is in Startup Items.
  • No spam in the Inbox.
  • SpamSieve log: one predicted spam matched from the blocklist.

The problem is not with SpamSieve but certainly with the Mac or with Mail (no surprise there, there are lots of little things that go wrong regularly with Mail). I suppose I have the choice of launching Mail manually or having it launch at Startup and then using Apply Inbox Rules. I think I’ll just stick with launching it manually after everything else and all is stabilized.

1 Like

Hello domellen,
I am running MacOS 10.15.6 and release version of Mail, SpamSieve 2.9.39…

Have noticed the issue slow startup of Mail and like you, my app is NOT in the log-in Items (but is always left running so I wouldn’t have noticed it as much, just tried in comparison now). I only have two items in my Login Items (CCC User Agent, Dropbox), neither appear relevant to this. I am not compelled to move Mail into log-in items because it means that it will start at will when starting up the OS. Not desired.

Like you, I have noticed that some junk does reappear in my inbox, but training it usually takes care of the issue for me. Biggest offender for me is Adobe which seems to use multiple email account for unwanted marketing purposes. I do have Adobe listed in my contacts but only as adobe.com, not the email marketing accounts. Working on training to overcome… My conclusion though is that SpamSieve is working correctly. Spammers (considering Adobe to be likewise, a purveyor of unwanted email) continually try to get to the inbox as you may well know. That’s why SpamSieve is and has been so useful for us.

Regardless, I do not hit Apply Inbox Rules…Just my 2¢.

H

That sounds like a good workaround. It might help to go to Manage Plug-ins… in Mail’s preferences and disable the SpamSieve plug-in, then restart Mail and enable it again. Some people find that this resets something in Mail that makes it launch faster, which seems to be related to it not applying the rules.

I’m seeing this, too. It took a while to observe, but I see what domellen and you are talking about. When I looked at my Mail (whether on Mac or another source, since on my Mac Mail was previously open it’s the same), that indeed it was the case and SpmaSieve recognized it, that none of the messages were being filtered. I turned Mail off.

Then I got the strange popup (after Mail closed and was manually re-opened), that SpamSieve’s reaction had been to turn its filtering on again.

Shouldn’t this be automatic when Mail closes (that it turns off SpamSieve and starts itself) after Mail reopens? I’ve never gotten a warming like this before that I remember. Anyway, the spam previously there (inbox messages) were automatically filtered.

So I guess your point about some weird interaction being in effect with Catalina updates (10.15.6) is well taken. Sadly I’m going to have to do the same. What’s strange is that the filtering seemed to work fine with Mail open for a time, then suddenly over a day or two this crept in, finally resulting in NO further filtering. Perhaps this is a clue for you Michael, should you want to pursue it.

FYI, I haven’t this sort of this in the small amount of time I’ve been testing with Big Sur beta and the a version of SpamSieve. FWIW…

That’s not what it was about. The reason SpamSieve turned itself off was not because Mail closed but because it detected that Mail had opened without loading SpamSieve’s plug-in. Without the plug-in, Mail would move good messages to the Spam mailbox, so SpamSieve turned off the rules to prevent that from happening. When SpamSieve detects that Mail has loaded the plug-in again, it re-enables the rules.

I did what you suggested. And now no spams are recognized as spam by SpamSieve.

I looked at the log and all the entries since August 13 (when I started fiddling with SS) are “Trained: Spam (Manual)”. There are no “Predicted: Good” or “Predicted: Spam” messages at all. Four spams are from the obviously same spammer, each with a different “from” address and a different “from” name. I thought that was why they weren’t caught but looking through the log it seems such messages, with changing names and addresses, are usually caught by other means, probable the Corpus.

From August 1st to 12, I count 65 items “Predicted: Spam” and 29 “Predicted: Good”. Since August 13, there are none.

I tried to create a blocklist item with the part of the name that does repeat, but it didn’t seem to work. Or maybe I didn’t do it right.

I checked everything as instructed on the help page “Why is SpamSieve not catching my spam?”. There is nothing amiss, as far as I can tell.

What do you suggest?

Should I just wait a while, as I’m not drowning in spam at this point?

Do the “Manage Plug-ins” thing again?

Or maybe, if all else fails, should I reset everything and start again? I would prefer not to as my blocklist and whitelist are years old. But if that’s the only solution, I’ll have to do it…

That makes it sound like either the plug-in is not enable or the rule is not active. If you can’t figure it out, please send in a diagnostic report.

What happened when you tested the rule? If nothing is amiss, that should have worked, and there should be a “Predicted: Spam” message in the log. But you said there were none.

No, that wouldn’t help. There’s no reason to delete the training data when the problem is that Mail isn’t even sending the messages to SpamSieve for analysis.

Thanks for sending the report. It looks like your SpamSieve [Score] rule in Mail is unchecked. Also, it’s set to only apply to messages that aren’t in your address history instead of applying to every message.

Wow! That was quick.

I had seen that the SpamSieve [Score] rule was unchecked, but since I hadn’t touched anything voluntarily, I figured it was supposed to be that way since the other two rules, with the colors, were checked. I should have read the manual again to be sure everything was OK but I trusted myself too much. Bad idea.

I have no idea how it got unchecked. Stuff happens…

I also have no idea why the rule was not set to apply to every message. Maybe, at some point in the last decade and a half, there was a good reason for this, but I can’t remember it. So, now, I just set it to Every message.

After that, the spam I had left in my inbox was correctly removed when I activated Apply Inbox Rules.

Problem solved.

You are, as usual, incredible.
Many thanks,

Just yesterday, my wife’s computer had a similar glitch after she restarted. The Mail application was reopened after restart and spam messages showed up at the Inbox (my wife noticed several that she previously manually trained as spam). I checked to see that SpamSieve was active (Manage Plug-In active), all the SpamSieve rules were turned on and it had sorted other accounts but not these message in one specific account (Google). The account was active.

It was only happening to the Google Mail folder. So, I did select the account sub-folder items (Inbox>Account Subfolder>All) and in Mail, Menu>Message>Apply Rules… Poof, gone. This seems relevant to this discussion, not trying to hijack it. See if this helps.

I think @domellen’s issue was due to the rule being unchecked. In your wife’s case, my guess is that SpamSieve temporarily disabled itself as a safety measure because Mail was taking a long time to launch (as can happen after a restart if all the apps are reopening simultaneously). If that continues to be an issue, you could click this link to tell SpamSieve to wait longer for Mail to launch.

Michael,

Sorry. But that wasn’t apparently the cause as she had noticed the issue way after her machine started up (a day) and the issue was of a recent nature (going by date and time of the offending spam). Something about Mail likely, but failing in the processing, junk->inbox, somehow.

When I saw it all was looking good in SpamSieve and Mail settings.

Henry

Just witnessed two more spam items. She sent them and manually trained them. These were not previously trained but very suspicious looking. Seems they should’ve been caught for lots of other reasons, right? Spam score, contents, etc.

Henry

If you are saying that the problem is that you need to Apply Rules, you should do that first, before training. From the log that you sent, it looks like SpamSieve automatically figured out that the messages were spam, so no training would be necessary. The problem is either that Mail isn’t applying the rules automatically or that it is but isn’t listening when SpamSieve says the messages are spam.

I suggest changing your account-specific rules so that the only condition is the one for the account. An extra Every message condition is not needed.

OK.

FYI. It has been working effectively the way it was for quite some time.

Henry

Taken care of. Don’t know why that extra line was there. It was also there on one other account that did not seem to exhibit a problem. Both are done the way you show it listed.

Henry