C-Command Software Forum

Yosemite - Spam identified but not moved

After upgrading to Yosemite, SpamSieve appears to be identifying spam (message is flagged “You marked this message as Junk Mail”) but is not moved to the Junk folder. The “Train as Spam” command does move the message properly.

Is SpamSieve coloring the messages as spam?

They are being coloured - mostly blue or gray

Please see the Why are messages marked as spam in Apple Mail but not moved? page.

error log attached

Error Messages.log (1016 Bytes)

Are you saying that when you did the test in #2 nothing happened?

well, yes, the whole issue is that “nothing” is happening - the spam messages are not being moved to the spam folder - do you mean something else by “nothing”?

on the other hand, if the message is marked as Spam and I choose “Train as Good”, nothing happens - it remains marked as spam.

Normally when people say that spam messages are automatically marked but not moved, manually applying the SpamSieve rule does move them to the Spam mailbox. Also, normally when the “Train as Spam” command works, the “Train as Good” command also works. So I’m not sure what’s going on on your Mac. Have you tried restarting it? Also, please send in your rules files and SpamSieve log file via e-mail.

Yosemite Mail Altered Preferences
FWIW: I too was having problems similar to the above.

When I checked my settings, I discovered that Yosemite/Mail 8.0 had reenabled my Junk Mail preferences (Junk mail filtering had been enabled/checked). Disabling junk mail filtering seems to have put things to right.

my Junk filtering was not re-enabled - not relevant in this case.

Actually, looks like the problem is actually being caused by another plugin - MailTags (indev.ca).

in my case, it is being moved, but it’s showing
I’m posting here in case the OP didn’t notice this (or perhaps my case is different).

On my machine, they are being moved into the Spam folder, but when I highlight “Inbox”, the messages are showing there anyway. Previous to Yosemite, those messages would not show unless I highlighted the Spam folder.

I also use MailTags, so maybe that’s why, but I haven’t tried deactivating that yet.

Inbox Spam Marked But Not Removed
Are you sure it’s MailTags? I went to the thread and it seems possible: If it interferes with selecting a message, then it might not be possible for SpamSieve to “grab” the message to move?

But…that seems a stretch? Is that how SpamSieve works?

InDev released an upgrade to MailTags yesterday: 4.1.1. I installed it, but the problem remains: email gets marked as spam but remains in the inbox. :frowning:

SpamSieve doesn’t have to grab the message. Mail’s own rule moves the message (if SpamSieve says it’s OK to) before the message is visible in the inbox to select. From what I’ve heard, MailTags is interfering with all rules that move messages.

Well. That’s annoying. Hopefully, they’ll fix it quickly.

Thank you for the response.

Best,
Keith

Solution
Looks like MailTags has a beta update. I installed and it fixed the issue. If you don’t want to have to wait for an official release, check out the thread on their site and install the beta.

Beware of MailTags 4.1.2 Beta
Thanks for the link, but when I follow it, I see that the beta seems to be crashing Mail and also seems to have some kind of trouble currently Things and OmniFocus (installed on my Mac).

:frowning:

Hopefully a fix is imminent.

Huzzah!
I decided to bite the bullet and manually remove the spam from my inbox, so I launched Mail and immediately got the 4.1.2 MailTags upgrade notice…no longer beta. It appears to have done the trick for now. I had to apply inbox rules to all my mail, but I have hope that new mail will get routed correctly to the Spam folder!

Now to figure out how to set up the iPhone thingy, because I think I would prefer that. :slight_smile:

Cheers, everyone!

Keith