C-Command Software Forum

Archiving Tweets Problem/Question

I’m not having good luck archiving individual tweets from the Twitter web site. When I do a share → EagleFiler from Safari, either in Web Archive or RTF I get a blank file.

If I do the parts in sequence manually, I can get a successful save. Am I doing something wrong?

EagleFiler version: 1.98, MacBookPro Monterey, Apple Silicon

Steps to successfully save a tweet (done manually)

  1. Go to URL of Tweet
  2. Change domain from “twitter.com” to “nitter.net
  3. Save result as a WebArchive in Safari
  4. Load WebArchive
  5. Import into EagleFiler

All of the separate parts work, when I start with a Twitter URL and import using EagleFiler I get an empty file.

Thanks for any help with this!

It’s not clear to me what’s going wrong here, as I just tested File ‣ Share ‣ EagleFiler Import in Safari, and it worked with Web archive, RTF, and PDF formats. EagleFiler should be doing the switch to Nitter automatically. Perhaps there is some information in the log that would explain why the pages were blank, or perhaps it would help to switch to a different Nitter instance.

Some other ways of importing that you could try:

The first three ways also involve EagleFiler loading the URL so they may encounter the same problem—but, if not, that would point to a problem with the Share command rather than with fetching the page.

The last way will transfer the content directly, without accessing the network, so it should be more reliable.

1 Like

Hi, changing the Nitter instance solved the problem! I went to a US-based instance - nitter.moomoo.me - & saving now works quite nicely, thank you!

1 Like