C-Command Software Forum

Cannot Add A Device To ToothFairy

Hi,

I cannot find a similar topic via search so I am asking it here.

I have just bought a new Macbook Pro (M1 Max) and have previously been using ToothFairy on my older Macbook Pro (2014 pre touch bar).

On my older machine, ToothFairy worked perfectly and I was happily shifting between headphones, mouse, bluetooth keyboard on my devices and loved the easy icon indicators to show me if a device was connected or otherwise.

However on my new machine, I can add the keyboard and headphones without a problem however the mouse is claiming it does not have the appropriate services “The device does not have the necessary services.”.

Why does it work on my previous machine (Big Sur) and not on my new machine (Monterey)?

All help appreciated,
D

I’ve not seen that error before. Could you clarify:

  • What kind of mouse is it?

  • Have you tried restarting your Mac?

  • Does the mouse already show up in System Preferences ‣ Bluetooth?

  • Does removing and re-adding it there help?

  • What about if the mouse is the only Bluetooth device paired with the Mac?

Thank you for the reply. The data you requested …

  • What kind of mouse is it?
    It is a Roccat Kone Pro Air. All of its functions are working including DPI switching, profile switching and the different lights for the different profiles.

  • Have you tried restarting your Mac?
    Logging out and restarting both.

  • Does the mouse already show up in System Preferences ‣ Bluetooth?
    Yes, I am using the mouse as a Bluetooth mouse. I just cannot use it in ToothFairy - that is add it and have its icon in the menu bar.

  • Does removing and re-adding it there help?
    I have tried this a few times at least.

  • What about if the mouse is the only Bluetooth device paired with the Mac?
    Have tried this as well and it does not show up.

To clarify it is the only device that is causing this issue thus far. I have added icons for my phone, second laptop, headphones and keyboard at this stag and everyone plays nicely.

Because of this I am leaning towards perhaps being the mouse and if so I will have to live with it - however it was working perfectly fine on my 7 year old laptop. Therefore what exactly is ToothFairy looking for to allow the Bluetooth device to be added to the menu bar?

Regards,
D

Could you explain this some more? In your initial post, I got the impression that the mouse was showing up in the list when you clicked the + button in ToothFairy but that you got an error after clicking Select. Are you saying that the mouse is not even available to select in the list?

Nothing. It’s just asking macOS to show the standard Bluetooth device selector, with no requirements on the type of device.

In the first situation … it showed up in ToothFairy and, when added to the list, the SELECT button was Greyed out - thus not allowing me to add the icon to the menu bar.

I then deleted/removed it from ToothFairy thinking I could try it again and it does not show up anymore.

When I removed it from ToothFairy it did not remove it from the Bluetooth Devices list in the Bluetooth preferences.

As of writing this I checked again and it showed up in ToothFairy again, however the SELECT button is still Greyed out.

Thanks,
D

Sorry, but I still don’t understand. If it’s already showing up in ToothFairy’s Preferences window such that you can delete it, why are you trying to add/Select it again?

That’s normal. Removing a device from ToothFairy does not unpair it from your Mac.

Okay something is being lost here …

When you add a device to ToothFairy, you must also click on the Select button in the bottom right of the interface to make its icon appear in the menu bar.

For the mouse, that select button is greyed out … this was not happening in Big Sur.

Thus I cannot add it into ToothFairy.

D

Yes, that makes sense. My question is, what does “I then deleted/removed it from ToothFairy” refer to? How did you remove it if you weren’t able to add it?

I think there was a glitch that somehow listed the Bluetooth items and had the word Remove next to them … I have not been able to replicate this situation since.

So my question is reduced to “why is the select button greyed out”.

D

OK, thanks for clarifying. I’m not sure why that is happening for some people on Monterey. I’ve filed a bug with Apple (FB9783884) and am working on a debug version of ToothFairy to investigate this in more detail. I will message you when that’s ready.

Excellent - thanks.

D

With ToothFairy 2.7.8, if you run into the macOS bug where a device cannot be added from the Bluetooth selector window, you can now add the device manually.

After updating, still cannot add the mouse to ToothFairy.

Here is the screenshot with the select button not available.

Screen Shot 2022-01-05 at 09.40.14

The keyboard rejection is because it is currently plugged in for recharging.

D

What happens if you click Cancel and the Option-click the + button as described in the dialog?

This method works, and it shows the mouse is connected. When I turn off the mouse (or plug it in for recharge) it shows that it is not connected - as expected.

However I am able to click the icon to disconnect, however it will not actually disconnect the mouse (the mouse still operates on Bluetooth) but the icon will show it was disconnected and clicking on it again will cause a “cannot connect to the mouse” error - even though I can still use the mouse.

D

Do you see different behavior disconnecting via the macOS Bluetooth menu?

Using the Bluetooth menu in the control centre (I am on Monterey) exhibits the same behaviour, except it will allow me to reconnect.

It seems that the Bluetooth will not allow this mouse to be disconnected unless I turn it off.

Maybe it is something in the mouse? I have noticed once or twice if I remove the mouse from the Bluetooth preferences, it finds two mice to connect to under the same name.

The mouse is a 3-way mouse - it can be tethered/wired, comes with a 2.4GHz dongle and can be used via Bluetooth (my preferred method).

D

Yes, it sounds like there’s something particular about that mouse or the way macOS talks to it. Unfortunately, an app like ToothFairy can only ask macOS to connect/disconnect; there isn’t a way to fix it at a deeper level if it reports an error.

If you send in a diagnostic report and a Bluetooth log I could make bug report to Apple on your behalf.

The error is only being reported by ToothFairy.

If I go through the same steps using the Bluetooth preference panel, it auto reconnects itself - the mouse cannot be disconnected from Bluetooth unless it is switched into another mode.

ToothFairy reports it disconnected (icon is black/clear instead of white) and “cannot reconnect” but the mouse is still connected to Bluetooth and operational.

D

Apple has told me that they consider it a macOS bug if the API that ToothFairy is using gives different results from System Preferences. So I think we should report this. You could first do it with System Preferences, and then ToothFairy, and then hopefully the difference will show up in the logs.