C-Command Software Forum

"Improve sound quality" feature not working

simple as that really its ticked but nothing happens.

also the shell script does work either, I have this pasted in it “#!/bin/sh
SwitchAudioSource -t input -s ‘MacBook Air Microphone’”
and nothing changes.

Sounds like a macOS issue. Are you able to switch the sound input manually (in System Preferences) or using SwitchAudioSource in Terminal?

Which device’s microphone is it trying to use?

I installed ToothFairy for the first time today and I discovered that I had to put export PATH=/usr/local/bin:$PATH one line before the SwitchAudioSource command.

i.e.

#!/bin/sh
export PATH=/usr/local/bin:$PATH
SwitchAudioSource -t input -s ‘MacBook Air Microphone’”

A post was split to a new topic: “Improve sound quality” feature not working after putting AirPods Max aside