C-Command Software Forum

Leopard, followed AppleMail plugin reinstall but not working

Morning,

First, condolences to the Spamsieve dev. It must be hellish getting the final build at the same time as all your customers. Thanks for being patient with us and hopefully the community is being patient with you as well :slight_smile:

I followed the instructions to reinstall the Spamsieve plugin and everything looks like its installed and working, but Spamsieve isn’t actually catching the spam. In addition, the “Training…” menu items in Mail don’t do anything.

For example, if I click on a spam email and click Message --> Train as Spam, nothing happens. I even went through the Spamsieve settings menu available in menu to set everything up again and double checked the rules.

Anybody else have something similar happening?

This is the first report I’ve seen of such a problem. Do you have any other Mail plug-ins installed in the folders:

/Library/Mail/Bundles
/Users/<username>/Library/Mail/Bundles

? If you open the Console application, do you see any errors in the Console Messages from Mail or SpamSieve when you use the training commands or Message > Apply Rules?

Not Working after Reinstall
I too reinstallled after upgrading to Leopard and it does not run at all.

I’m not sure what I did to fix it but its working now. It might simply have been rebooting that kicked something into gear.

I did have MailActon and MailTags installed but have since removed them. Between rebooting, cleaning out InputManagers, and deleting extra scripts from apps I’m no longer using, something fixed it.

My apologies for not being able to give more specific info.

Me, too
Hi, I’m having this problem, too. SpamSieve appears to work (launches, “Train as Spam” will move a message to the Spam folder, etc) but it won’t actually catch any spam before it lands in the inbox. No console errors when applying rules. I used to have MailTags and ActOn installed but they were deactivated during the move to Leopard and aren’t in the /Bundles directory anymore. I don’t have any other bundles installed.

I did notice that, after installing Leopard, the SpamSieve rule was mixed amongst some old Mail ActOn rules, including the ‘Stop Processing’ rule, so I deleted those. Now the SpamSieve rule is the only one. Not sure yet if that’ll do anything.

FWIW, when moving to Leopard I did an ‘archive and install’ rather than a straight upgrade.

Also, the amount of crud now in my Inbox is showing me quite effectively how well SpamSieve was working before!

hmm… the issue has returned. Now Spamsieve isn’t working again even though it appears to be installed.

I noticed that Spamsieve doesn’t launch automatically anymore when Apple Mail is checking for new Mail. When I launch it manually it still doesn’t work, meaning selecting a spam in my inbox and doing Train as Spam through Mail’s menu doesn’t do anything.

Things seem to be working now
OK, so having deleted the Act-On rules (bearing in mind that no Act-On Bundle was active) now things seem to be working. I sent myself a message and then quickly quit and relaunched Mail. On the relaunch, checking for mail resulted in SpamSieve starting up, my test message being delivered, and four pieces of spam getting caught directly in the Spam folder. This is the first time this has happened since upgrading. So maybe Act-On’s left-over (and misplaced) “Stop Processing Rules” rule was the problem after all. But this is just a guess.

That sounds right to me. And, if you don’t want to delete the Act-On rules, unchecking them or moving the SpamSieve rule to the top of the list should also work.

Please answer the questions in this post. Do you have any Mail rules besides the SpamSieve one?

Hi Michael,

Spamsieve is the only bundled installed in:

user/Library/Mail/bundles

There is no bundles dir in the main Library/Mail dir.

Right now its started working again and I don’t know what triggered it. Next time it stops working I’ll be sure to open the console app and look for any errors.

Spam Won’t Delete
I reinstalled SpamSieve after installing Leopard and that went well. It catches spam as before, but I can’t delete the spam. When I select messages in the spam folder and delete them, it looks like they’re getting filtered again and put back in the spam. The rules seem to be the same as before. Any ideas on how not to refilter deleted messages?

Are you using POP or IMAP? Is your Spam mailbox local (On My Mac) or on the server? Are you able to delete messages in other mailboxes (particularly mailboxes that you have rules filtering messages into)? If you open SpamSieve’s log, do you see new “Predicted” entries for the messages that you think are getting filtered again?

Leopard Apple Mail - Now Working

I’m using POP. My spam mailbox is local.

However, I found the problem. Something got messed up with my spam mailbox. When I rebuilt the mailbox, I could then delete the spam and it would stay deleted. Thanks for the help. SpamSieve is great.

I’m having similar problems. The bundle gets disabled every time.

No other bundles are installed.

http://homepage.mac.com/knussear/Picture%201.png

Have you tried restarting your Mac?

Hi Michael,

Okay, started happening again. Spamsieve was working perfectly this morning and now its stopped again even though the app is still running.

Here is what console.app reports when I select a spam message and to “Train as spam…”

10/29/07 2:41:40 PM 2007-10-29 Mail[216] An exception was thrown during execution of an NSScriptCommand…
10/29/07 2:41:40 PM 2007-10-29 Mail[216] Could not create mailbox with name:Spam. Reason:The mailbox “~/Library/Mail/Mailboxes/Spam.mbox” already exists.

Hopefully that’s helpful. I’m not terribly familiar with console.app so if there is something specific I can do to get you a better report, please let me know.

This looks like a bug in Mail. The good news is that by the time it agains to this point it’s probably already trained SpamSieve with the message (you could check SpamSieve’s log to be sure) so you could finish the job manually by deleting the message or dragging it to the Spam mailbox.

Training Doesn’t Work
Installed Leopard. Now, if I click on a spam email and click Message --> Train as Spam, nothing happens.
I’ve done everything mentioned here on the forum. So, I too am having this problem.

What does the Console say? Does “Train as Good” work?

Training Doesn’t Work

Same here (I get the same report in Console as “knight777”). But: when I do “Train as Spam”, the background of that email in the inbox list gets a colored background. Same background color with ALL emails I tried.

“Trains as good” won’t work here, neither. After training as good, marking in the list and trying “Trains as spam”, same as before is happening (not moving the email as in the rule and giving it a background color in the list).