C-Command Software Forum

Mojave Mail doesn’t like SpamSieve

I’ve just installed Mojave and SpamSieve doesn’t work with even though it’s the new update SpamSieve. It keeps asking to install the settings in Mail preferences it each time I do, and restart Mail as instructed, it still unchecks SpamSieve in Rules.

Do you see the SpamSieve commands in Mail’s Message menu? That is how you can tell for sure whether the plug-in is loaded. It’s important to give SpamSieve Full Disk Access in addition to enabling the plug-in using the “Manage Plug-ins…” button in Mail’s preferences.

Also, you can click this link to enable some debug logging so that SpamSieve will show (in Console and diagnostic reports) why it thinks it needs to deactivate the rules.

Yes, done the full disk access and and enabled plugin but I still get the message telling me to do that… check box enabled for Rules too

Do you see the SpamSieve commands in Mail’s Message menu? After enabling the debug logging, please restart Mail (so that SpamSieve will check the plug-in) and then send in a diagnostic report.

maybe fixed
Okay, after several; failed attempts, I deleted the plugin, then reinstalled. The message telling how to install suggested I look in preferences>general>manage plugins, there I found that Spamsieve wasn’t checked on so I checked it.
It now appears in the Mail Messages dropdown so that seems to have fixed so far… if others are having the same problem then try the above

This didn’t work for me. I uninstalled/reinstalled plugin and made sure SpamSieve was checked in Manage Plugins. It would work once then, when I closed and relaunched Mail, I would get a dialogue box indicating SpamSieve had been disabled. I would check Manage Plugins and SpamSieve would again be unchecked. I even went so far as to uninstall the plugin, then the Spam Sieve app, followed by a computer restart and SpamSieve reinstallation. Not even that worked.

Under Preferences>Rules, only SpamSieve was checked. There was another rule, apparently installed with Mojave, that was unchecked. Does it even need to be in the Rules section at all?

Is your Mac’s home folder stored on the same volume as your Mojave installation? That’s the only time I’ve heard of Mail losing track of which plug-ins are enabled.

If this happens again, right after you restart Mail and find that SpamSieve has been disabled, please send in a diagnostic report.

Yes, this is explained in Steps 5–6.

Progress made but issue not resolved

I followed the instructions and every item went as stated except, under step 9, I was not asked my Mojave for “permission to control Mail and SpamSieve” but I believe I granted that the first time I launched SpamSieve earlier today. I did discover 2 things. First, I had not properly set up my SpamSieve rule. That was corrected. Second, I discovered that, when I launch, close, and subsequently relaunch Mail, SpamSieve alternatively activates or deactivates its Mail rules. Per your instructions, I saved a diagnostics report for both events. Excuse my lack of knowlege, I’m new to the forum. How do I post or email the diagnostic reports?

Perhaps this is because the plug-in is alternately enabled and disabled?

Please e-mail it to spamsieve@c-command.com.

Diagnostic reports emailed

I think that indeed is what’s happening.

If you click this link to enable some debug logging, future diagnostic reports will record why SpamSieve is deactivating the rules and what it thinks about the state of the plug-in.

Thanks for sending the reports. I will look some more tomorrow, but at first glance I don’t see anything out of the ordinary that would cause Mail to disable the plug-in after it was enabled (which I can see that it was).

Can you confirm that your Mac’s home folder is not stored/linked/synced to another disk, i.e. you are using a standard setup with everything stored on the Mac’s internal drive? It looks that way, but I want to be sure.

Link click and confirmation

I believe my (Mac’s) home folder is solely on my Mac Pro’s internal SSD. Due to the space limitations of the Mac Pro’s SSD (512 gigabytes), I do have my documents folder, photo files, iTunes library, etc. stored on an external Pegasus RAID system but the Mail folder is stored internally on the Mac Pro and not stored/linked/synched to the Pegasus RAID. A Time Machine backup for the Mac Pro is stored on an external LaCie drive; the Pegasus is backed up to a Crashplan cloud account.

OK. Please enable the debug logging as described above. I would then recommend that you restart your Mac in safe mode and see whether the problem occurs when only using Mail and SpamSieve. If the plug-in still gets disabled, please save another diagnostic report.

If you are able to enable the plug-in and have it stay enabled after you click “Apply and Restart,” does it immediately get disabled again after the next time you launch and quit Mail?

No issue in Safe Mode

The issue did not occur when I booted my computer up in Safe Mode. I opened, closed, and reopened Mail 5-6 times while in Safe Mode and not once did the issue occur. It reappeared when I restarted my computer normally though.

Well, that is progress. This would seem to indicate that the problem is related to some extra software that’s installed on your Mac. A next step might be to see if the problem occurs if you disable some or all of your login items to see if a particular one is the trigger.

Or, after the plug-in does get disabled, you could send in a new diagnostic report, and it’s possible there would be information there that would help me figure out what’s happening here.

One issue resolved but one created

I have determined that, unlike the past few versions of OS X, a conflict exists under Mojave between iLock (a third party app to password protect individual applications) and SpamSieve and that seems to be the cause of my problem with SpamSieve and Mojave Mail. As per instructions and with Apple’s help, I booted into Safe Mode and went through my log in items. Initially, iLock didn’t seem to trigger the problem as a log in item; however, the first time I launched Mail after ending the phone call with Apple the issue began anew. I went back and deleted iLock as a log in item, restarted my computer but the issue persisted after I launched iLock manually. I ultimately disabled iLock and the problem with SpamSieve and Mojave Mail has so far not repeated itself again. That’s the issue that was solved.

The issue I discovered is that, even if iLock is removed as a log in item, it apparently loads automatically any way. It’s way above my pay grade to understand how iLock launches automatically but that’s what’s apparently happening. As long as it’s enabled and loaded, whether automatically or manually, I have the problem with SpamSieve and Mojave Mail.

Glad you figured it out. I will talk with the iLock developer and see whether there’s anything that can be done. Mail on Mojave is very sensitive about plug-in files not being touched/moved.

Maybe it installs something in the LaunchAgents folder? Is there a way that you can control which apps/folders it is locking? For example, it might work better to only lock the ~/Library/Mail/V6 folder, not the entire Mail folder (which includes plug-ins).

Could you confirm whether you are referring to this iLock or another app?

I’m not positive this can be done but I suspect not.

Yes, that’s the one.