Problem after Sonoma upgrade

Continuing the discussion from Updating SpamSieve and Mail Settings for macOS 14 Sonoma:

Hello. I upgraded to SpamSieve 3 shortly after it came out. I was using Ventura and Apple Mail. Everything was fine. Today I upgraded to Sonoma. I deleted the Mail rule for SpamSieve. I activated the SpamSieve extension. I confirmed that Apple Mail doesn’t have Enable Junk Mail filtering checked. I checked that SpamSieve has Full Disk Access. The training options for good and spam messages are grayed out in the SpamSieve icon in the Menu Bar. Any ideas about what I’m doing wrong? Thanks.

The ones at the top of the menu in the Apple Mail section:

should never be grayed out when you are in Apple Mail.

The ones in SpamSieve’s Message menu will be grayed out when you’re not in SpamSieve because they apply to the message selected in SpamSieve.

Hmm. I could swear it wasn’t working before, but it is now, so that’s what matters. Thank you very much!